Web app that worked with Xojo 2014.x shows Internal Server Error with Xojo 2015.2

I haven’t dug into the error logs yet, but I thought I would ask if there was some guidance I missed about updating web apps to Xojo 2015? I am running CGI apps on a linux platform.

Any insights?

It might help to completely remove the app files (config, appName.gci, appName) and especially the libs & resources folder from the server and then try reuploading.

Those things often change and if you’re using automation to upload there could be old ones of those sticking around. Not sure if it’s related to that error but this was always a problem I run into when uploading after updating to a new Xojo version.

Separately depending on your budget you could look into using Xojo Cloud as it’s a lot more consistent with correctly handling new versions and uploads.

I actually ran a new experiment on a brand new directory.

  1. created a new webapp - single web page, single label on that page (saying “this is a test”).
  2. compiled with x2015.r2, uploaded to location on server, pointed browser to that location - Internal Server Error.
  3. same code, compiled with x2014.r3.1, uploaded to same location, pointed browser - works fine.

So clearing out the directory isn’t the problem.
Any other insights on differences between 2015r2 and 2014rx ?

Maybe it’s related to the plugins you’re using for each version of Xojo on your machine? Those will affect the built/run apps in WE. Do you have different MBS plugin versions in 2014r3.1 than you do in 2015r2?

Nope, same plug-ins. But those aren’t even invoked in the simple test app. I do have MBS main, curl, dynapdf installed for both versions. But as I said, same version.

I do no web programming but read about this.

http://www.xojo.com/blog/en/2015/04/linux-libicu-and-xojo-2015-release-2.php

Could this be related to your problem?

[quote=199763:@Torben Vikow]I do no web programming but read about this.

http://www.xojo.com/blog/en/2015/04/linux-libicu-and-xojo-2015-release-2.php

Could this be related to your problem?[/quote]
That’s a real possibility - I will try that after I get back to my office in a few hours.

OK - struggling to find 32 bit library, but did install 64 bit - though I think this is a red herring (i.e. not related to the problem).

I need an expert from the Xojo community to tell me what changed between 2014r3 and 2015r2 so I can use my updated software to keep working on my apps.

Please!

Libicu is the most likely candidate in my opinion. What OS is running on your server?

Centos 6

I used…
Sudo yum install libicu

I could not figure out the correct designation for 32 bit.

Try

sudo yum list libicu*

Installed Packages
libicu.x86_64 4.2.1-9.1.el6_2 @base
Available Packages
libicu.i686 4.2.1-9.1.el6_2 base
libicu-devel.i686 4.2.1-9.1.el6_2 base
libicu-devel.x86_64 4.2.1-9.1.el6_2 base
libicu-doc.noarch 4.2.1-9.1.el6_2 base

installed libicu.i686

Problem now solved! Thanks.

To bump a sort of old thread, I have this exact same problem and confirmed it’s the ICU library. I cannot seem to get 32bit libraries on ubuntu 10.04.

apt-get install lib52
apt-get install lib52:i386
apt-get install lib42:i386
all fail with the “Couldn’t find package option”

lib42 IS up to date, probably in 64bit format.

I’m getting really tired of chasing xojo around with linux distros, it’s like every release requires me to have a new flavor of distribution or introduces new dependencies that don’t work with the previous flavor; all while still being handcuffed by not being able to build for 64bit systems. I get the files are smaller, but FFS, stop deprecating my operating systems every 3 months. Let me decide to link against the system’s libicu library or bury it in my app at compile time.