Web-App doesn't start after updating to 2018-R1.1

Hi everybody!

My CGI built on version 2017r3 works perfectly.

on version 2018r1 or 2018r1.1 does not.

The webpage returned the error message:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator at webmaster@dev.msidatastore.com.br to inform them of the time this error occurred, and the actions you performed just before this error.
More information about this error may be available in the server error log.
Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

I’m on a centos 7.2.

Already installed libunwind (libunwind.x86_64 2:1.2-2.el7) for my CENTOS 7.2 server.

Same error…

Follow the suggestion to disable SELINUX, but my server does not have the /etc/selinux/config

Any help?

Check status of selinux on command line: sestatus

check the path /etc/sysconfig/selinux

sestatus: command not found

/bin/ls: cannot access /etc/sysconfig/se*: No such file or directory

I just logged into my Centos 7.4 server and checked and

sestatus: disabled

cd /etc/sysconfig/selinux (config file is there)

Silly question: Are you sure the old web app wasn’t running when you uploaded the new CGI file?

you need libunwind8 (i don’t see you say “8”)…

I believe libunwind8 is a debian named package

RedHat (rpm) it is libunwind.x86_64 2:1.2-2.el7 (or whatever the current rpm is)

ok, then he needs to check if all libraries that xojo compiled are executable inside the webserver.
and they must have been ftp’ed or transferred in binary mode.


I’m with you on double checking all required libraries and also on ftp transfer and permissions

Is your web app built as 64-bit? if not, you’ll also need the libunwind.i686 package.

use ldd to find lost lib.

yes… sure


msidatastore@msidatastore.com.br [~/dev.msidatastore.com.br/cgi-bin/devmsidatastore]# ldd devmsidatastore
linux-vdso.so.1 => (0x00007ffeaaf1a000)
XojoConsoleFramework64.so => /home/msidatastore/dev.msidatastore.com.br/cgi-bin/devmsidatastore/./devmsidatastore Libs/XojoConsoleFramework64.so (0x00007fca25909000)
libc.so.6 => /lib64/libc.so.6 (0x00007fca2553c000)
libgobject-2.0.so.0 => /lib64/libgobject-2.0.so.0 (0x00007fca252eb000)
libglib-2.0.so.0 => /lib64/libglib-2.0.so.0 (0x00007fca24fd7000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fca24dbb000)
libdl.so.2 => /lib64/libdl.so.2 (0x00007fca24bb7000)
librt.so.1 => /lib64/librt.so.1 (0x00007fca249af000)
libm.so.6 => /lib64/libm.so.6 (0x00007fca246ad000)
libunwind.so.8 => /lib64/libunwind.so.8 (0x00007fca24493000)
libunwind-x86_64.so.8 => /lib64/libunwind-x86_64.so.8 (0x00007fca24273000)
libc++.so.1 => /home/msidatastore/dev.msidatastore.com.br/cgi-bin/devmsidatastore/./devmsidatastore Libs/libc++.so.1 (0x00007fca23ec2000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007fca23cac000)
/lib64/ld-linux-x86-64.so.2 (0x00007fca27e1f000)
libpcre.so.1 => /lib64/libpcre.so.1 (0x00007fca23a4a000)
libffi.so.6 => /lib64/libffi.so.6 (0x00007fca23842000)

Is there a write permission for the “config.cfg” ?

[quote=389340:@?? ?]Is there a write permission for the “config.cfg” ?

yes, it is set to 666

just to be more clear than ever:

i have the same project built on 2017r3 and 2018r1.1
the 2017 works fine, the 2018 does not.

one (2017) is on msidatastore.com.br (port 8081)
and the other one (2018) on dev.msidatastore.com.br (port 8082)

Can you install the 2017 version also on dev.msidatastore.com.br (port 8082)? Just to make sure everything is working.
Do you have or can test other server version like CentOS 7.4 or 7.5?
Can you share your project with someone with access to other version like Ubuntu?
Can you test locally or use a service like digitalocean or vultr, to test other installations?

I know this is not ideal, but I think that is hard to find the problem and the more tests you can do the more information you will find.

Out of curiosity, have you tried just running the binary from the command line to see if any other errors are generated?

[quote=389384:@Alberto De Poo]Can you install the 2017 version also on dev.msidatastore.com.br (port 8082)? Just to make sure everything is working.
in fact on version 2017, i always have both sites up and running. i develop a new version, upload to dev then my client checks before i upload to production site.

my virtual machine at my mac runs ubuntu 14 server. both versions 2017 and 2018 runs fine.

no, i can’t. there are sensible information on project

i test locally on ubuntu

the big problem here, on my point of view, is that i’m doing the same thing about 3 years, on same project. then only on this particular change, from 2017r3 to 2018r1.1, it just does not work! at all