Ventura: Dock and recently opened (Xojo built) apps

I’ve just had a first quick look at the macOS Ventura (Beta).
I noticed that a running app shows in the Dock (well, that’s obvious). When Quit, it remains in the Dock-area where the “recently opened apps” are.
However… non of the Xojo-built apps (downloaded, notarized, just built / don’t know about mac app store apps) remain there. They always “disappear” from the Dock (unless pinned to the Dock) right after being quit. Which is odd and unexpected.

And I’m wondering - is this just me and my “Ventura VM (Intel)”?
Do others see the same (with Xojo built apps)?
If so - is there some new setting (e.g. in Info.plist) needed to make the apps stay in the dock’s “recently opened apps area”?

I see that very rarely and not related to Xojo apps.

You are limited to 3 Recent Apps and a rollover was done. If you have more opened that not permanent into the dock, when quit she’s vanished automatically from the Recent part of the Dock.

This started to appears in the last released Monterey(s).

There is a Preference (Control Panel) you can set to stop that.

No rollover… Here’s a quick Screen Recording showing what I mean.

The app ‘Test’ is built with Xojo (just an empty desktop app). It always disappears from the Dock when Quit. All other apps (Terminal, System Information, …) stay in the area. And yes, there could be that “rollover” later, when opening several apps.

What I’m wondering is why the Xojo-built apps (any that I have tried) never stay there after “Quit”.

It is normal for apps to disappear from the dock when they are quit. They only stay there if you have an installer or set them to stay (Application icon > Options > Keep in dock) or drag the icon to a new location on the Dock using the mouse.

In recent macOS versions they added a “recent apps” section to the dock akin to the iOS one. I can confirm the setting exists on Big Sur. Article: How to Hide Recent Apps from Dock in MacOS

Jürg’s video shows that a Xojo made app isn’t staying there.

Ah, I must have turned that setting off long ago. I don’t like recent apps, as it never has the one I want.


Yup. And I’m still wondering:

  1. Have I messed up this Ventura Installation?
  2. Has Apple messed up this dock behavior in Ventura?
  3. Do Xojo built apps need something they don’t have by default, so that they behave “normal” regarding “dock behavior”?

I tend to 2-1-3, but kind of hope it’s 3 (so that it can be fixed somehow) :wink:


I’ve just figured it out - it’s neither 1, 2 or 3 - it’s 4:
If I move the .app in to the “Applications” folder (or a sub-folder within “Applications”) - then it works as expected. And that’s the same behavior on Monterey.

When I’ve been thinking about what might be different then it occured to me that I’ve just dropped the “apps to be tested on Ventura” to the Desktop (or a subfolder in Desktop), whereas on my main machine I’ve put them in “Applications”.

1 Like

Ah, yes. Apps outside of Applications work differently. I’ve forgotten what it’s called but they are “sandboxed” in some fashion.

Are you thinking App Translocation which occurs when an application has the Quarantine bit set (generally after downloading).

Another macOS Behavior (from Apple Silicon days) is the way the Applications folder is reset after an OS update:
I sort the applications in this folder as Apple (OS) Applications on top, my installed applications (Firefox, LibreOffice, Xojo, etc.) at the folder bottom. The folder is “snap to grid”.

After each macOS update, I found the folder set to automatically alphabetized. Boring.

Yes, that was the name, but that isn’t what’s causing this, as no download has happened. I’m thinking of apps outside of the Applications folder causing issues, for example even now help bundles don’t work when the app is outside of Applications.

Hi, I hope this is relevant to your issue, but I’ve just had feedback from Apple reviewing my App, and they cite one issue … “Specifically, if we tried to close the app via cmd + q and or the red title bar button, the app remained open and it removed the top menu bar and the dock on macOS.” … is this the same issue as yours? I am running Ventura beta 10.

This sounds unrelated to the original post, but in the past, your issue has been caused by situation where a window had Window.MenuBarVisible = false (which is mis-named, on macOS and Windows, it actually hides the Dock / TaskBar)

Any chance that’s happening to you? (maybe you should start a new thread…)

Help bundles didn’t work at all with earlier Monterey releases, only Apple’s apps. It’s why I took the time to write my own help system as an application like App Wrapper needs to have it’s help accessible.