Variables not working in debugger

For some reason my debugger window will not show anything in the variables section. I have reinstalled Xojo, tried different versions, restarted my machine; all to no avail. Any ideas what I can do? Having trouble uploading a pic… But, it is all blank, no variable names, no values. I can tell that it is a listbox and I can click on rows, but those rows are completely empty.

Would really love some help on solving this one.

Standard information to help:
Mac OS version?
Xojo IDE version?
Do you have a screenshot of this behavior?

OSX 10.13.2
Xojo 2017r3, also tried various flavors of r2

How does one get a screen shot in this forum? I cant get it to work…

Erin, you may to use the img tags and image sharing service like imgur/imgbb to get your screen shots.

Is there somewhere besides Application Support that Xojo stores preferences? This problem is also happening with r1 which makes me think a setting got flipper somewhere. Is there anyway to clear out all of xojo’s prefs?

I have never seen this before. I recommend creating a new user account and trying it there to see if it is related to prefs.

If it works in the new user account, you can go back to the problem account and try removing everything Xojo related from these locations:

  • ~/Library/Application Support
  • ~/Library/Preferences
  • ~/Library/Caches

Restart Xojo, log into your account to grab the license and try again.

If you continue to have trouble, you should probably contact technical support:

~/Library/Preferences was the problem
Thank you!