.Value ?

I searched what .Value is (in Xojo), minutes ago, thinking there certainly is a meaning I do not know.

But, the site (extract below) does not says that:

[code]thefreedictionary.com/value

val·ue (v?l?yo?o) n. 1. An amount, as of goods, services, or money, considered to be a fair and suitable equivalent for something else; a fair price or return. 2. Monetary or material worth: the fluctuating value of gold and silver. 3. Worth in usefulness or importance to the possessor; utility or merit: the value of an[/code]

I checked TextField, TextArea and Label, all have .Value to get its contents as String.

What a strange idea.

Well… it all depends what the String value is entered on those TextField, TextArea and Label controls :wink:

Anyway, .Value seems really fair and it fits really well in my opinion… even it unifies the way to access the contents on these and other class instances :slight_smile:

i think value is more for a number and not the best name for textboxes.
but consistent.

.Text was deprecated because “Text” became a datatype. You can still use .Text, though.

Even in France stupid people exists.

As an example, they use coefficient as a number with the currency symbol. :frowning:

For me, this looks like a price, not a coefficient. And this number is used as a coefficient.

You didn’t read Wikipedia yet i see…:wink:

I read Wikipedia each and everyday of the year. Please share a link.

As of yesterday, the last stable version is Xojo 2019r3.1 :wink:

[quote=497372:@Emile Schwarz]Even in France stupid people exists.

As an example, they use coefficient as a number with the currency symbol. :([/quote]

No good example. You see those everywhere. For example talking about small numers greater zero. Those call it the modern Epsilon. :wink:

https://en.wikipedia.org/wiki/Epsilon :smiley:

You mean 3.2, or?

I meant nothing, this is what wikipedia wrote…

https://en.m.wikipedia.org/wiki/Value_(computer_science)

The forum removed the last ), here is the link with it
https://en.m.wikipedia.org/wiki/Value_(computer_science)

Thank you.

IMHO it should have been “.stringValue” that way the datatype is apparent from the name.

That might not have have fit with the API 2 drive to name many things similarly
Otherwise we’d need stringValue for textarea & textfield, booleanValue for checkboxes(maybe), and I dont know what for others

[quote=497580:@Norman Palardy]That might not have have fit with the API 2 drive to name many things similarly
Otherwise we’d need stringValue for textarea & textfield, booleanValue for checkboxes(maybe), and I dont know what for others[/quote]
Correct. It would still be consistent as per say, but abundantly clear.

It would
Just not what they chose to do
Oh well