Valentina flashing errors

I’m getting a dialog box that lasts a mere 1/10 of a second. I captured it by taking about 30 screenshots in a row. Here it is:

First of all, it’s strange to me that it vanishes. Quite annoying. As I’m typing this it flashes up and steals focus then vaporizes only to return. It’s basically rendering my machine inoperable.

Here’s what’s happing in the console. In a stroke of luck I actually captured the error unintentionally when grabbing this screenshot. Frustrating given that I failed so many times trying to apprehend it at the outset.

According to the system prefs panel the server is shut down.

Where do I go from here?

happing = happening. That’s due to the flashing error that grabs focus.


When I installed the latest version of Valentina on Windows I had to put the license in the server folder of the installation folder (I think).

I wasn’t able to get the server running without the license in place. I think Ruslan has posted they have fixed that issue by allowing the server to run on one connection without a license.

Ok, I’ll see if that’s the issue. Regardless, this isn’t really a conventional way of dealing with an unlicensed product. An annoying occasional popup would suffice. This is bordering on psychotic aggravation.

It eventually stopped on its own. But now it says the server is running.

This is what was happening in the console immediately after the error quite spawning dialog boxes.

LOL I couldn’t keep the server running until I put the license in the correct folder.

The Logs went from 43 to 117 between those two screen shots. I’m not sure where that file is located though. It’d be nice to have a “show” button for that instead of just a “clear.”

Found it. Here’s the last log:

Mon Oct 7 2013 13:45:01.056982 (TID 140735165256064): Database engine inited

Mon Oct 7 2013 13:45:01.062906 vserver_x64 (Type x64, Server 5.4.3, Kernel 5.4.3 )
vKernel is externally-synched type.
Maximum number of connections: 0

WARNING: Owner name/email are missed in the INI file. It is highly recommend to fill it up to let Valentina team contacts you in case of vServer crashes.

Mon Oct 7 2013 13:45:01.087383 (TID 140735165256064): VProject facilities are available
Mon Oct 7 2013 13:45:01.087438 (TID 140735165256064): Server started
Mon Oct 7 2013 13:45:01.087451 (TID 140735165256064): Non-secure port: 15432
Mon Oct 7 2013 13:45:01.087463 (TID 140735165256064): SSL port: 15434
Mon Oct 7 2013 13:45:01.087474 (TID 140735165256064): SNMP port: 15161
Mon Oct 7 2013 13:45:01.087557 (TID 140735165256064): ERROR: Not found any valid license.
You need to get a FREE license with 5 connections OR purchase a license with more connections at
Paradigma Store
You will get your license file by email. Drop it into licenses folder and start server.
Mon Oct 7 2013 13:45:01.087589 (TID 140735165256064): Shutting down server…
Mon Oct 7 2013 13:45:01.094739 (TID 140735165256064): SNMP agent terminated
Mon Oct 7 2013 13:45:01.095080 (TID 140735165256064): Bonjour service unregistered

Once you get a license installed you should be up an running.

Thanks Johnny. I’ll get right on that. I’ll admit my error here but Paradigma clearly needs to remedy this. It’s a bizarre way to handle an unlicensed product.

This is right, you need drop license file into folder “licenses”.

Joseph, have you see my post about idea of 1-connection without license at all?


Next 5.5 and next 5.5b30 will have this. Works really more easier!

[quote=38965:@Joseph Claeys]Thanks Johnny. I’ll get right on that. I’ll admit my error here but Paradigma clearly needs to remedy this. It’s a bizarre way to handle an unlicensed product.

Actually this is side effect of “restart after failure” – default for OS x daemons. Can be changed if needed. Described in Apple docs.

On linux we get the same if we want using bash loop.

On Windows, in Services property you also can choose how to behave if deamon crashes. On default also to restart it.
Windows allow yet choose what todo on second crash and on third crash.

Flashing up a dialog box that I can’t even interact (or even read as it vanishes so quickly) doesn’t strike me as standard OSX behavior.

Dialog about allow or deny you show, comes from OS X FireWall,
I think you have enable it on your computer.

If you want access VServer from another computer, then ALLOW this to it.

Aha, it flashes ?? Never have see such.
May be you can allow VServer via prefs panel “Security & Pricacy” - right in your firewall.

Well, I think this was result of no license, so vserver did start and stop.
This is why OS X have show you that dialog as flashing.

It’s definitely an OS X dialog related to the firewall. I’ve had the same “flashing” experience with other apps. If the app starts and can accept incoming connections, the dialog box pops up. However if the app immediately closes/stops, OS X closes the dialog box as the app is no longer running. It appears as a “flash” as the dialog box opens then quickly closes because the app stopped.

Further comments on this topic should be addressed to Valentina support directly.