Using Bob Delaney's fpPlugin on an M1 mac

I’m trying to use Bob’s fpPlugin and I’m not having any success. The documentation states “fp Plugin was programmed in C++ and compiled with Xcode 12.2 for the Mac Intel and Arm64, mingw for Windows, and Ubuntu for Linux.”

However I have placed the plug-in in the ZOJO plugin folder and it doesn’t load.

On the intel mac that’s all I needed to do to use the plugin. Has anyone used Bob’s plugin on an M1?


I’m embarrassed. I had asked the same question well over a year ago (my search failed and the post was archived) and Steve Jones helped by suggested resetting the quarantine flag. It worked then but now it seems the plugin needs Rosetta to run.

The error is
fpPlugin.xojo_plugin (dlopen(/var/folders/jq/03hhmgw90z1cjchjgp4fz2nw0000gn/T/NUyztG.fpPlugin64.dylib, 0x0001): tried: ‘/var/folders/jq/03hhmgw90z1cjchjgp4fz2nw0000gn/T/NUyztG.fpPlugin64.dylib’ (mach-o file, but is an incompatible architecture (have ‘x86_64’, need ‘arm64e’)), ‘/usr/lib/NUyztG.fpPlugin64.dylib’ (no such file), ‘/private/var/folders/jq/03hhmgw90z1cjchjgp4fz2nw0000gn/T/NUyztG.fpPlugin64.dylib’ (mach-o file, but is an incompatible architecture (have ‘x86_64’, need ‘arm64e’)), ‘/usr/lib/NUyztG.fpPlugin64.dylib’ (no such file))

I though the plugin supported ARM but I guess it doesn’t


I just downloaded and checked the version available on the website. The dylib in the arm64 folder is x86_64 so the plugin doesn’t actually support arm64. I suspect you’ll have to build intel until this is fixed.

Bob, I’d love to hear from you to support fpPlugin with Plugins Pro.

Best wishes,
Tim Parnell

Thanks for checking the fpPlugin status.
I have a new M1 and am holding off installing Rosetta while I identify intel only apps.

Thanks again,

I asked Bob Delaney to update his fpPlugin for the M1 many months ago, but he said at this point he had no plans to do this. He did offer to provide us with the materials so we could do this ourselves. I ended up switching my programs entirely to MBS plugins, but there are a number of functions provided by fp that are no supported in MBS, so I do hope someone with the time and capabilities can generate an ARM64 version of the fpPlugin.

I’ll bet Christian can add those, if asked.

Thanks to both Tim and Robert.
I’ve marked Robert’s answer as the solution since it seems we will have to move on. Too bad since the plug-ins he provided were superb. It would be nice if XOJO had these built in or was able to support Int128 and UInt128 variables.

But I emailed with him some months back and provided details on how to port the plugin!?
I assumed he would do that.

Prof. Delaney’s plug-ins are essential. I corresponded with him about his matrix plugins, without which my neural networks are helpless. He wanted to help, but… I am now looking to work with a consultant to get the matrices updated. If there are others I should coordinate with instead, I am all ears.

I contacted Bob Delaney last year in May 2021 about a possible release for Mac M1. He replied within a day, saying that he was able to re-compile it for M1 and he’d updated the version on his site. Brief release note from his site:
“Version 11.0 adds support for Arm in MacOS”
I downloaded it and ran it, but since I don’t currently own an M1 Mac, I haven’t been able to test any M1 builds.

My experience was slightly different from robert’s. I, too, contacted bob about the complex matrix plugin, got an immediate response followed by an updated code and an invitation to “try this”. I did on my M1 and it failed.I sent the error response to him and he said he needed to do more work in Xcode. That was months ago. Does anyone have a Delaney plugin that has been successfully updated and which works on an M1?

@Björn_Eiríksson or @Christian_Schmitz sometimes rescue plugins. Pinging them both to bring this to their attention.

As far as I know he does not supply the source code. If it was then I would be happy to put it in my Open source rescue plugin program like the TextInputCanvas plugin.

Looking at his plugin though then it does have Apple Silicon segment. It might not be code signed or maybe its the strange space in the name of the Apple Silicon segment in his plugin that causes it to not work.

(Either of those problems people could unzip the plugin, and fix and re-codesign and Zip it up again I guess)

At the top of this thread I had looked inside. While there is the macarm folder, the dylib inside is x86_64. That doesn’t fool a M1 without Rosetta installed. From the way everyone describes Bob talking about the plugin, it sounds like he might be okay with giving it a new home. I haven’t reached out because I don’t know enough to help here.

I can host and maintain it if he is really looking for that and keep it free. (Open or closed source depending on his wishes)

The last time I emailed with him, he wanted to port it himself.
So maybe ask him again?

I can send him an email and try to coordinate a peace treaty :slight_smile: It would be nice not to lose this plugin. If anyone is already friends with Bob, perhaps they could point him toward this thread?

I have a busy day it won’t be until much later that I can start this process.

1 Like

I have been friends with Bob Delaney for many years, and I just emailed him again. I can confirm that he posted a version of the FP plugin on his site which was labeled as ARM64 compliant, but it is not. I let him know about this, and will post any response I get on this forum. I do know that Christian offered to help him port his plugin, and I hope he will offer his help again as many of us have relied on the FP plugin for many years. I ended up switching one of my programs entirely to MBS, but have others that simply will not work without the FP plugin. Those are stuck in emulator mode on M1 macs.

this story deeply reminds me of an old plugin for 4th dimension I had to leave because I couldn’t port it from 68000 pascal code to powerpc C code. since then, I avoid plugins for anything even if I wrote them…


I contacted prof. Delaney one more time. He responded quickly asking if I had gotten the complex matrix project he posted to me on the Xojo forum. I do not know what that means.

Maybe in your forum inbox, if you click your icon at top right. That’s the only idea I got.

1 Like