UseGDIPlus in Paint not reliable

I wanted to be as unobtrusive as possible in a subclass, so I tried to set App.UseGDIPLus = True in a Canvas Paint opening, and put it back to what it was before leaving the event.

What I found was that it did not work reliably. It did alleviate the platform not supported error upon compile, but upon run, the Alpha channel was not taken into account, and all colors were solid.

In another project I built to make a feedback report, it works (normal, just like the TV that works at the repair shop).

So I will just share it here : better set it up in Open…

You know it’s a switch now in the IDE?
It’s in Build Settings for Windows.

Part of the trouble I was having yesterday, by the sounds of it.

Try turning it on just to call “new picture” and then flip it back right away. I think you’ll have better results.

[quote=237932:@Tim Parnell]You know it’s a switch now in the IDE?
It’s in Build Settings for Windows.[/quote]

I am creating a custom control, so I do not want to force the user to set it.

I need it to use a color with Alpha channel in Paint. That is why I tried to use it there.

For a picture, indeed, it works just fine.

I believe your trouble was essentially DoubleBuffer preventing transparency. I do not use DoubleBuffer. But indeed it looks alike.

I also have a crash using an object2d in a mask’s graphics when GDIPlus is on.

Whao. Not sure that was even envisioned when mask was developed. Maybe time to use Alpha Channel.

Bug reports about these issues would be great and help get them fixed.