URLConnection Question

I am recoding an older utility originally written in an older version of XOJO to grab data from a public website. The old HTTPSocket worked fine, but has since been deprecated and I can’t get URLConnection to work. Even with the sample code that is included with the latest XOJO Release, entering in the URL returns a 404. An example URL is Trademark Status & Document Retrieval As mentioned, even the basic URL example code provided by XOJO (xojoexamples\Networking\URLConnection [the get example]) results in a 404 error code page being returned, but the same URL can be placed in any browser to received data and it worked with HTTPSocket in the past. Any ideas?

It seems the US Patent and Trademark office has an API that you should be using instead of scraping data from the user facing website: https://developer.uspto.gov/api-catalog/tsdr-data-api

Building a simple test app with the URL provided I get HTTP status 200 and the unloaded content I expected. The user facing website uses Javascript to asynchronously load the item in question, so you are going to face other kinds of difficulties once you figure out why your code is getting a 404.