Upgrade blues. Moved from 2019r3 to 2021r - Error signing application

Moved because I had to for the App Store and iOS14.

Error signing application:/Users/mike/Documents/Code/ProView3_golden last/Mobile/ProView3.debug.app/ProView3.debug: resource fork, Finder information, or similar detritus not allowed

Yes I ran "sudo xattr -cr “/Users/mike/Documents/Code/ProView3_golden last/Mobile/ProView3.debug.app”. Rebooted Xojo. Still blows up. Deleted app directory, tried to run again. Still no joy. This simply a debug run, not one character has changed in the code, and deprecations have been honored.

Where do I go from here?

TIA, Mike

Did you upgrade Xcode on your machine?

Absolutely. No Betas, but 12.5.1, with all the tools and the iOS 14.4 simulator. My little Swift test app survived Transporter just fine. I deleted the earlier revs.

If you turn off App Store and run, does that work?

No. I’m merely trying to run the app in debug mode in Xojo to start. Same error.

This is not a build, yet, although I’m desperate to get one out.

Steps taken:
Upgrade to Xcode 12.5.1
Install new Xcode tools
Install i* Simulator 14.4
delete Build directory
ran "sudo xattr -cr “/Users/mike/Documents/Code/ProView3_golden last/Mobile/ProView3.debug.app”
Possibly not in that exact order.
Blow stuff up.

Have you actually run the new Xcode yet?

Do you have more than one copy of Xcode on your machine? If so, have you indicated to the system that 12.5.1 is the “current” one?

Yes, and no.

Even ran xcode-select -switch to make sure. Also, in frustration, I rebooted the machine (MBP M1) as well.

Does your project have any post-build steps that could be adding things to the bundle that the codesigning process doesn’t like?

No. None at all.

well… you could try adding a build step script between the build and sign steps that runs that xattr command to see if that’ll fix it.

DoShellCommand("xattr -cr “/Users/mike/Documents/Code/ProView3_golden last/Mobile/ProView3.debug.app")

I inserted that script between Build and Sign, and got an additional error after the original one: " IDE Script Compile Error. " - something, something 24, line 1 (which contains just the xattr command.)

I ran the xattr command manually, as well, just before a debug “Run”. Same result. I am puzzled.

Try adding “Print” in front of the DoShellCommand.

I still get the original “Error Signing” message; and then…

Of course, there’s No such file; it hasn’t been created yet.

xattr: No such file: “/Users/mike/Documents/Code/ProView3_golden

xattr: No such file: last/Mobile/ProView3.debug.app

Do I need a backslash before the space, even though the command is in quotes?
Hoo Boy, yes, I did that, and and now the No such file error message was concatenated.

Hello?

Sorry. I’ve been answering you on my breaks.

So I’m going back and looking at your original message and noticing that it’s the debug app that’s being signed? You’re getting this error when you run in the IDE?

Could you also verify in the iOS build target that you still have a Team selected?

You might also want to try turning off Build For App Store and seeing if you can run then.

…aaand suddely it works to both run and build. Uploaded successfully to App Store. Weird.

Sorry, was away week of the 4th. Not sure what changed… :wink:

But Thanks.

Siri: describe 'iOS development’ …

1 Like
Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.