Updated Windows 10, now Xojo boots sl-o-o-o-w

I succumbed to the demands I kept getting and updated my Windows 10 to version 1903 and now everytime I run my app from within Xojo, it’s a 30-second wait. That used to be 2 seconds or so. The update also caused me link problems of previous file links within my Xojo app.

Anyone else experiencing this problem?


  • In addition, check apps running in the background. 1903 has several and you can deactivate many of them.
  • I also had an issue with Windows Defender sucking up immense amounts of resources for a few hours after upgrading one of my computers. That eventually subsided and the machine came back to its old self. I suppose that it performed a full scan of everything on the computer and then left things alone.

Yep. (OneDrive). Could that be it? I did get a message about it not being linked (or some such thing) so I went through and did the update on that.

If your project is not on a oneDrive folder, then oneDrive is not a factor.

In my experience, Horrible things happen if a documents folder is fully synched with OneDrive or iCloud.

better to have your projects on a partition which is not synched automatically, or an external fast drive, and drag the data over manually now and then as a backup.

I think I’ll move the project back to C. I don’t need to use OneDrive since I’m only working on it from my desktop (at least for now).

Stay away from Cloud Drives with your Project Files. There are many many Threads/Cases in this Forum describing all the nasty things that could go wrong. :wink:

Better create a GitHub account and Sync or use somethin like GoodSync or alike.


good advice. I moved the project back to my C drive and, after a tremendously long initial Run, it now Runs swift as ever. So I guess problem solved.

Thanks to all.

Well, I spoke too soon. Now, each time I RUN the project, it’s a 1 in 4 chance (or maybe better) that I’ll go into the “Not Responding” mode for up to 2 minutes. Then it kicks in and all is well.

I moved the project to the C drive. It seemed to help at first but I hadn’t given it a good enough test drive.

Then I added 4 gigs of memory to my rather puny 4 gig machine. Now there’s plenty of memory but no speed improvement.

I wonder if the project is spending time linking the project library up or something but it makes no sense to me that about 3/4 times, it runs fast as ever. There’s really no pattern to it that I can discern … as of yet, anyway.

Anyone with any suggestions would be appreciated.

Try clearing the cache ( %appdata%\xojo )?

You do that in the Build settings? Cause I found a button there and pressed it.

Seems to be running better. No delays after 10 runs or so. Thanks.

Did you tried to load other project(s) ?

Hard disk fragmentation (splitting up) ?

Boot disk: HD or SSD ?

… was it Windows uploading tons of data ?