Update Bundle ID Issue

I recently noticed an issue when I was trying to open one of my Xojo apps to work on it. I had not worked on this app for a while. When I opened the app I received and alert box that said:

“Please resolve the following issues. If you don’t resolve them now you can resolve them in the future”

There are two issues then listed.

  1. “Updated to Cocoa” - “App framework updated to Cocoa for OS X builds”
  2. “Update Bundle ID” - “The app bundle ID needs to be set”

If I click close, the IDE opens with the name of my app at the top, however, the remainder of the App is not present. No windows, controls, etc.

What do I need to do to resolve / fix this issue.

Also, I recently noted that some of my older apps are saved with the extension “.xojo_binary_project”, I don’t recall seeing that before and my new apps do not have that extension.


How old is the project? I would attach it to a private feedback case because @Norman Palardy was trying to figure out why some older projects aren’t opening in the Xojo IDE.

The alternative solution is to slowly upgrade the project through older RealBasic / RealStudio versions.

The last time I worked on the project was 10/10/2017.

I’m sorry, for the issues you’re seeing the last version of RealBasic / RealStudio you used before everything disappeared is what I was asking.

There are some rare RealBasic projects that are having issues being opened in Xojo. If that’s not the issue you’re having my post is irrelevant :frowning:

I used the VB to Xojo converter program and having the same issue. Trying to load using the 2017 ver of Xojo.