Unable to locate database

MACOS 10.11.6; XOJO 2016r4.1; iOS app

I have an iOS app that runs AOK in the simulator, everything works as it should.

When I install on my iPhone(4s) and run, I get a message that says “Unable to locate database.” and it points to the app’s document folder. The copy file step is OK and after the build step. I have program that can look at the app’s document folder on the iPhone and the database IS there, current and contains the needed data.

What do I look for to remove whatever is causing the “Unable to locate…” message?

TIA, Tony

I don’t know about the copy file step actually working then. Make sure it’s set to both to Both debug and release.

FWIW, I don’t use the copy files step. I put the script in my app and create the database on the fly. They way I’m in control of when/where it goes.

And once you’re off the simulator, there’s not a lot you can do to track stuff down. I have a log function that writes to a text file in the documents folder, and I’ve set up the plist so I can share the document with iTunes and I start logging information in that file until I get it figured out.

I don’t have the link off the top of my head, but the ability to share documents through iTunes is a small plist modification. Search the forums for UIFileSharingEnabled.

Bob, the copy file step IS set for both. As I indicated I can ‘see’ the database on the iPhone in the app’s document and it is correct; but, when I run the app I get the unable to locate message.

I will search for UIFileSharingEnabled and see what happens.


Tried all of the suggested routes but no joy. So… what I did was rename the database and changes all references in my app to the new name. It worked. Why? I have no idea, but at this point I’ll take the win.

Thanks to Bob for his assist