Unable to edit WebListBox Header Row

Recently updated from 2019R3.1 (which I only briefly had a chance to play with) to 2020R2 and appear to be missing an option to edit the header row or add new entries from the design surface. There also appear to be a number of property options missing from the inspector tab. Do these all now have to be added in code? Apologies if a n00b question, but have been unable to find anything about this.

1 Like

I have the same problem. Why is this post withdrawn?

Accidentally withdrawn rather than edited by the OP (me). Anyway, I added the config code, header and initial rows to the control’s Open event. Now trying to figure out using Bootstrap for CSS as Webstyle designer has been dropped.

I’ve found the “solution” in another post in this forum: it’s a bug. If you save your project as text project and not as binary project the bug does not appear. You may save your project as text project, as soon as you have a licensed product.

I don*t have one, therefor I can save a project in binary format only.

And yes, I set the properties as you described, via “open” event.

Yes, I saw the same thread and tried the suggested solution. Unfortunately it didn’t work for me.

It didn’t work for you. Does this mean, that that if I buy the PRO version I still have the problem, even if I save the project als text project?

These are not good news :frowning:

So the web app examples provided with Xojo 2020 R2 which contain WebListBox components, at least those that I have tried, also do not expose have the editor-based configuration options we are referring to (the example web projects are also provided as binary files but makes no diff if saved as text). From what others have written, I suspect the WebListBox component underwent a major re-write for Web 2.0 which would mean a significant change to the layout editor for that (and presumably other) web controls. Personally, I’m getting used doing it via code but it may be worth asking Xojo devs about it.

1 Like

I think Shane is talking about the difference on the actual WebListbox representation in the IDE and the Styles section from 2019r3.1:
and now the IDE can’t show the Initial Values and there is no Style section in 2020r2:

The problem with saving as Binary is here:
when you save as Binary and load back the project, you get this:

In all my tests, saving the Binary as Xojo project, closing the project and loading the Xojo project version “fixes” the problem:

Hi Albert. Thanks for this. Yes, one issue was the ability to configure the number of columns from the property inspector. The other to enter rows into the table and populate them at design time. Both do-able in 2019 but in 2020, changing the number of rows in the inspector doesn’t change them on the layout at design time AND you can’t populate them like this:


That ‘fix’ doesn’t work for me :thinking:

And yes, the other issue is around styles; it was a doddle to tweak and set them on various controls in 2019. Not so much now. But that’s a separate problem lol.

The “fix” is not to be able to do something like your screenshot, the fix is to only have the “pencil” for the Initial Value that when you save as Binary and load the project the pencil is gone.

When you click the pencil on Web 2.0 a dialog shows for you to just add values like this:

Without that pencil, then the only way to populate a weblistbox with initial values is using code.

Are you saying that even when you save the project as Xojo project and load it again, that pencil is missing?

(The screenshot was merely showing where I got to in 2019). Anyway, I created a new project,saved it as non-binary, reloaded and the pencil now appears. Was able to enter row\column values and they appear when compiled and run. Strangely they don’t appear in the WebListBox in layout mode in 2020 but they for ListBox for 2020 and WebListBox for 2019. Thanks v much for your help. :+1: :+1: :+1:

1 Like