Unable to deploy to Cloud

Just bought into Small Xojo Cloud option to start testing app deployment.

Managed to get this working for the first few deployments, but now see two symptoms with no resulting success

either - the process seems to go through the motions, but I get an error saying:

“An error occurred during Xojo Cloud deployment” Please try again in a few moments.

or - the process seems to stall when “Sending Application-name to the Xojo Cloud” - the count down timer increases rather than decreases.

Any help/advice appreciated.


Hi Stewart- I will try it here and contact you.

Me too having trouble with deploying applications to Xojo Cloud Server (in Chicago)!
We have been testing our application as well as some sample programs – working fine until last week. Then the deploy process suddenly refused to cooperate at “Preparing MyApplication for deployment to Xojo Cloud. This will take a moment.”

It just hangs, also for DialogsExample.xojo_binary_project in the example folder.

We sent a mail a week ago to xojo, but haven’t got an answer yet – after 6 days! With the cost of these servers, this is expensive.

Can anybody offer some suggestion on what to do?

I’ll PM you and make sure you are taken care of.

I will PM you as well Stig. We don’t have a record of that email.

This was addressed.

Thank you, guys! This forum certainly has a MUCH shorter responstime than custserv@xojo.com.
(By the way, what happened to my picture at this forum? Now I have only an ugly sign to the left.)

custserv@xojo.com is for licensing and pre-sales support. This page has information about technical support options: http://www.xojo.com/support/technical.php

Make sure Gravitar is set up with the same email that you use with your Xojo account.

I buy Xojo Pro and Xojo Cloud Medium and I can not deploy to Xojo Cloud. My server is Chicago

In Abimael’s case, he did not provide all necessary information for the SSL certificate. It indicates that all fields are required but it will accept an entry without all of the fields filled in. We’ll be correcting that soon.

Deploying to Xojo Cloud has worked for me a few times, but lately I have been experiencing some problems.
Several times the countdown timer has stopped at remaining 0:00 and nothing more happens.
In those cases the problem disappears if I wait several hours/overnight before trying again.
This is annoying, but not fatal.

Now I have a real problem: I get a message saying “An error occured while connecting to the Xojo Cloud server. Please wait a few minutes and try again.”
I have waited a few minutes, a few hours, overnight, … same message.

Is there anything I can do to get out of this situation? Any help appreciated.

First of all, it would be helpful to know what version of the IDE you are using. It’s gotten better over time, so newer is better.

If you are using 2015r1:

For the error where the timer gets down to zero, be sure to give it a few moments. What should be happening is that the IDE is trying to connect to your app. Once it does (or does not) you should see a browser or an error dialog. We have seen a scenario whereby he upload counter gets to 99.9% and just hangs, but have been unable to reproduce it ourselves. Please try adding a webpage to your project (which you don’t necessarily need to use) to increase the file size and see if that works.

For the error regarding not being able to connect to your server, there are two common scenarios. The first is that he Firewall has temporarily locked you out. This can happen if you try to connect using two or more methods at the same time (like SFTP, Tunnel, Deploying). It’s also worth noting that using a Ping utility should be done sparingly. If you do use one, I would stop after 2 or 3 results because that will get you blocked for a short period of time.

Either of these scenarios may be cleared up by a server reboot, but if they persist you should contact technical support and have us look into it.

Thanks for the hints, my problems are now solved (I even found a stubborn bug in my code!).

A server reboot solved the connect problem, which I suspect was because I inspected the files created (or not!) on the server using another application (WinSCP). I do not think I was connected with both at the same time, but now I am aware of the problem.
If the firewall blocked me ‘temporarily’ - I think a couple of days is long enough :wink:

I am using 2015r1 (which btw I think is the best version I have ever tried).
As to the countdown, I have tried to wait for the browser to load for 'a ‘while’, up to several hours… The problem seems to disappear overnight, and deploying the same app the next day usually works.

Again, thanks :slight_smile:

Same problems here. I’ve been working on an app for a month, and it has deployed successfully and consistently.

Suddenly, deployment has starting hanging at a countdown of 1 or 0 seconds left. The log shows all kinds of timeout errors.

I restarted the server, deleted all the deployed apps, restarted the server again, and I still get the same issue. Sometimes, a tiny test application (just a couple of controls to have something to upload) deploys, but sometimes it hangs. But anything of any size (regardless of what’s in the code) seems to die.

Deploying to which data center ?

I’m looking at your server now. I will email you with some ideas.