Unable to delete a file type

The docs say…

[quote]Removing File Types
With the cursor in any field of the File Type, click the Remove button on the command bar to remove the file type from the set.[/quote]
No matter what field I click, nor where in the filetype definition I place the cursor, I can’t get the “delete” icon to enable nor the EditMenu:Delete to enable.
What am I missing?
Xojo 2018.2 and 2018.3
Mac Mojave

Are you saying that the icon is always gray and can’t click on it?

When I add a file type I get this:

The third icon changed and I can click on it to delete.

That’s exactly what I’m saying, Alberto. I’ve tried selecting a file type just as you have shown, and that 3rd icon with the minus sign never becomes enabled. Did you take this screen shot on a Mac with Xojo 2018.3?

Yes, new project, macOS 10.12.6, Xojo 2018R3.

Posting for the benefit of the archives…
Opened the project on which I am working in Xojo 2018.3
Completely selected the fileType I wish to delete as in the screen shot posted by Alberto
The “minus” icon stayed disabled.
Before posting a Feedback report, I tried with a new project.
I could create a new FileType and easily delete it using an now enabled “minus” icon
Went back to my current project to grab a screen shot for the Feedback report.
Voila! The “minus” icon was now enabled and I was able to delete the fileType from the current project.
RESULT: Weird IDE behavior