Unable to connect anymore to developer.xojo.com OR doc.xojo.com

Obviously I can still log on here but this is a bit strange.

Usually my method for searching is simply to use google. Then from those results I can choose to read the info from developer, the docs or this forum - I find this very convenient. It’s only been the last 2 days but now I can’t access them. I get an “Unable to connect” Error in FireFox 56.0.1 (64-bit).

Actually, come to think of it, I did update to the latest version of FireFox around the same time. Maybe that’s got something to do with it.

It’s really p*ssing me off - Any ideas?

Clear browser cache or test porn-mode - sorry private/incognito browsing :wink: ? I got into similar situation with some sites after a recent Chrome update. Clearing everything or browsing incognito solved it, but do remember - https://xkcd.com/1817/

Thanks Mattias - tried both methods and still have the same issue. Also this machine is only used for “scientific purposes” :slight_smile: Also have Norton Security. I’ve been very careful not to load any dubious software or websites.

But It gets worse.

Now after some more checking I’ve realised that I’m ONLY able to connect to this site and my banking website - oh, Ebay is also working and some others but not all.

There must be some “permissions” setting that must have been changed?

[EDIT] PayPal also works - seems like the more ‘legitimate’ sites are still working

Wow - that’s a narrow white-list… Must be something in Norton protecting you from The Dangerous Internet. Wish you luck trying to configure Norton. Sadly I don’t have any experience there.

In my case it was a site experimenting with HSTS (enforcing HTTPS) that I happened to access while they tested and that bad setting got stuck in my browser’s cache.

Works for me in Spain. But note, is http://documentation.xojo.com/ no http://doc.xojo.com/

Try a traceroute to both, perhaps a routing issue with your ISP.

Note developer, docs, forum and are in different networks.

[code]$ host xojo.com
xojo.com has address 174.138.47.113

$ host forum.xojo.com
forum.xojo.com has address 67.207.86.242

$ host documentation.xojo.com
documentation.xojo.com has address 174.138.40.53

$ host developer.xojo.com
developer.xojo.com is an alias for xojo.helpdocsonline.com.
xojo.helpdocsonline.com has address 34.198.78.234
xojo.helpdocsonline.com has address 52.4.108.171
xojo.helpdocsonline.com has address 52.202.227.192[/code]

Thanks. Those links don’t work for me.

Although, If I type in the url directly using https:// then I get there. Seems to work for other sites too but most of my bookmarks don’t work, and if I search for a xojo question in google then none the of links will go the web page.

Could it be that Norton is set in such a way that it allows you to only access secure sites (read https) and not the http sites?
Probably most of your bookmarks will use http and therefore won’t work?

Thanks Paul, Yes, it does seem like that is the case.

I’m not sure if it was Norton or FireFox, but to be left in this situation without any prior warning is very poor programming. Whatever happened to POLA? ie. the “Principle Of Least Astonishment”.

Looks like I’ll just need to update/edit my bookmarks - or delve into Norton, which I really don’t wish to - I just want to get on with my code.

Baaarrrrggggrrrrhhhhgggrrrumphhh!!!

I have been removing Norton from PCs for many years now. It’s caused too many issues and with all the recent problems with Anti-Virus software I usually uninstall anything except Malware Bytes or Microsoft’s Security Essentials. I’ve so far had no issues with those.

I’m sure there are tons of people using the others with no problems, but I’ve found too many people have issues with anti virus software and it can be a vector itself so be careful out there. :slight_smile:

Thanks Kevin. My subscription expires in 3 months so that should give me enough time to look at alternatives. Yes, I’m beginning to think that there is a problem with some anti virus software causing the problems that they were meant to eliminate.

There was an article not long back about a well known anti-virus company that ends in ‘y’ and is hard to pronounce, that apparently could/is being used as some sort of back door hacking tool - or similar.

cheers :slight_smile:

“His name is Voldemort. You might as well learn to say it.” :stuck_out_tongue:

Don’t you mean Voldemorty ?