Unable to activate my license #

First of all, I do not know why my license # have to be re-installed (or reactivated).

Now, I am unable to get back my license number and then I cannot build application(s) anymore, even with plane mode ON.

El Capitan
Xojo 2015r1

My license file was downloaded from the Xojo (My Account) web site), and I have only one Macintosh.
(And unlike what is in the web site, the biit was done on the integrated SSD I use since end of december 2014 / I do not booted on an external hard disk).

I just checked (and this is worst): same appli for my Windows Laptop running Windows 10 1709.
Note: my license covers the three OSes (and I have only two hardware / VirtualBox ran Linux Mint until some days ago when I trashed the Linux Mint folder.

Help ! Hilfe ! À l’aide…

Hi Emile,

Maybe you can try this: Go to your user account under Xojo.com and deactivate the active(s) license(s) in the affected computer(s); then logout/login in the Xojo IDE and download and active the license under the computer you want to use it.

…Or contact with Customer Service: https://www.xojo.com/company/contact.php

Good luck!


The joys of phone home DRM. Yecch.


Am I the only one in that case ?

Edit: Fortunately, tthis does not happens when I was with a Client :frowning:

Here’s what I got when I want to activate my license number connected to the internet:

I already stated this, but I have only one macOS computer (plus a Windows 10 Lenovo laptop). How can this be ?

Also: a click in the More Details button leads me to a page that allows me to downlad the application :frowning:
Probably a redirection made when the current site appears months ago (the embedded link is now broken).

Proposing to disallow a license without telling me which one it is is useless for me: it can report the trouble to my Window 10 laptop. (that is already excluded).

What happens if I am in a meeting with a client and no internet connexion is available ?
Why Xojo wrote things in my computer without permissions to do so ?

Go to xojo.com and log in to your account.
After login, press the Licenses tab and remove the current license by pressing the grey circle with the cross, in front of your license.
You should be able to active your license again in Xojo.

Instructions unclear, I’ve now downloaded a happy, but confused, person…

@Emile Schwarz — if you are still having trouble, send an email to hello@xojo.com and they will help you with this.

A further test (offline, after a reboot and a change of wifi location) leads me to the same state: unable to build any application.

Now I fear if Xojo disappears: I will no more be able to build application(s) with a valid license # :frowning:

This wifi hot spot is very slow, but I wil clear this computer license and re-enable it. If this works, I will do the same with the Windows laptop. More details later (if any).

The mystery deepens…

This is after removing the license for the El Capitan laptop.

One more test (the PC) and I will send a mail as Greg suggestion (thanks Greg)

Doh: this does not say that the license was not set into Xojo. Of course, I quit / launch Xojo after each change (to be sure).

Edit: 0 available on max 3 ! (and only one set according to my account)…

Last: Your account have no current license key… None set in my account !

I apologize for any inconvenience. We needed to make a change on the backend for security reasons and this has adversely effected some users using older releases of Xojo. These older releases are intermittently reaching out to an old authentication system. Though it sounds like you perhaps had at first used all your activations, once you do have a free activation for that machine, signing in to a new release gets older releases to use the new system. Download a 2017 release and Sign In on that release, then launch your older release and you should have no problem Signing In to it then.

Maybe put a Note on the License Page for others to know? :slight_smile:

Alyssa: no need (for me) for apologizes, just information. So, thank you for the information.

I will follow your advice when I will be really awake.

Sascha: you are right. I always think a simple notice is far better than silence.

Alyssa: can you delete this conversation: no need to fear some potential clients.
(I’ve made a screen shot of your text for my reference).

Thanks @Emile Schwarz, we’ll leave this here for anyone else who might search for a solution.

@Sascha S , I appreciate the suggestion but this only effects a few people who are using old releases. I’ve answered this question on the forums before, the workaround is also in the Dev Center and Feedback and only an email away if anyone writes to me :slight_smile:

A typical problem of phone-home DRM.

Are there any arrangements in place if something happens to Xojo as a company?

I do have one software package that I can no longer install because the developer company has disappeared.

I too. Worst, I have many unsupported software (I am in this racket business since early 1980).

And I will not talk tou you about buggy software that was never updated (stays buggy)… Notably an assembler (language) software that do not know all opcodes (mirco-processor) it is meant to use…

I failed miserably (lack of current license #; license # for 2017r2.1).

When I run 2017r2.1 and tried to apply my (2015r1) license # it was rejected (as I expected). I quit.
I run 2015r1 and try to apply the license # and it was rejected too.

So, to date, no more application build for me.

Please write directly to Customer Service, we can help you there - hello@xojo.com