Typing in Language reference window

The new Help window that opens in 2018 R3 for language reference includes a field at top to enter text to be searched, in Windows I can type text but it is not visible.
After pressing Enter it is searched and then I can enter new text at the Search field below Search results. Seems like top field is using white for color.

Odd, I don’t see that. Could you post a little video of it happening or a few screenshots?

I typed some “fffff” at top, search worked fine but text is not displayed at top while typing.

Ah the online view of the in built LR, I always use the local copy so I don’t see this view.

Try launching Internet Explorer on your machine and visiting http://documentation.xojo.com/ which is basically the same thing that’s happening in the online LR.

If that works then the only thing I can think is that they have set up the browser version incorrectly for the native view in the LR.

To check that launch regedit and have a look in:

Computer\HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION

and see if Xojo.exe is set to (11001)

If it doesnt work in IE at the first test, you might have some kind of browser plugin or anti-malware/virus software that’s causing issues?

Tried IE, Edge and Chrome with provided link. The page is not exactly the same and there is no field and navigator / icon bar at top (first row is green bar), only the smaller one at the left and in all browsers I can correctly type and see the text, notice that this left field also works in LR.
Value in Registry is as you mention 11001

This window isn’t new. It has been present for many versions if you set your preferences to go online to view the help. That said, the search field in the body of the web page is part of the web site being viewed. The search field at the top is not. They’re unconnected and there’s no decent way to echo the field from mediawiki to that one at the top.

Not exactly, I click at the top field but no cursor is displayed, then I start typing and the text is neither displayed (not at top and not at left) but after pressing Enter the search starts for this text.
In Mac it works the same way but the text at top is correctly displayed.

Oh I see, at the very top, sorry Alejando, I was looking at the wrong text box. Yes I see your problem with no text being entered.

I’ll make a ticket about it in a moment as I’ve found another bug while looking into this…

Thanks Julian, will try to get used to the left field :slight_smile:

I did a test on Mac (after some time until I found how to get that view) and it works correctly.

On my Windows 7 laptop, nothing appear at the top field (beside History icon), same behavior as Alejandro reported.

feedback://showreport?report_id=53910

And here’s the other bug I found: feedback://showreport?report_id=53911. Made me chuckle :slight_smile: