TypeMismatchException after update from 2015R2.2 to 2015R3

I updated to Xojo 2015 Release 3 with 64Bit-Support, marked in Build-Settings - Linux the deployment as x64, tested my app on my local machine, compiled, uploaded it to my server and started the standalone-app it via terminal. Everything worked fine. But when I open my Web-App I get a TypeMismatchException. In XOJO 2015 Release 2.2 this error doesn’t occur.

Anybody else also had this issue? Might be there is a flaw in the new distrubution?

It’s XOJO 2015R1 where it’s working, not 2015R2.2. With later versions I had a problem with libicu

Do you use WebRadioButtons in your project?

If you compile as 32-bit, does the app still work properly?

Thank you Greg. Indeed, I use WebRadioButtons.

I compiled as 32-bit, but the I ran into the libicu-error I fight with since XOJO 2015R2:

Runtime Error
Please report what caused this error along with the information below.
RuntimeCore/ICUStable.cpp: 79
Failure Condition: sLibraryPtr
Could not load ICU library
Aborted

Manually installing the libicu-library causes my plesk-panel to crash, so I developed under 2015R1 and waited for 64-bit-Support.

ICU is a required thing now
Some linux distros include this library or a compatible one by default
Others dont

We cant fix that issue for you on whatever distro you’re using
There have been other posts about solutions people have posted for various distros

Thanks Norman.

My linux distribution has a 64-bit ICU. Thats why I waited for 64-bit support from Xojo.

When I start my standalone-web-app in terminal as 64-bit-app, the ICU-error doesn’t occur. I was happy about this but ran into the TypeMismatchException when I called the app in the browser.

@Greg: What is it about WebRadioButtons? Can you give me a hint what to do?

You can see the app in action on my homepage (Videos) and starting the app with a testaccount

Frank, webradiogroups aren’t working well in 2015r3, see this feedbackreport:
feedback://showreport?report_id=41235

Thanks to all. I’ll wait for the next fix :slight_smile: