Trying to deploy Web App to Godaddy


I am trying to deploy a web app to Godaddy. I have followed Bob Keeney’s training video from his website as faithfully as I am able (The video was made in 2012, and used BlueHost rather than Godaddy).

To simplify things, I created an app named junk and compile it to a Linux app It consists of a webpage and a button that does nothing. Using Filezilla, I uploaded the result of my build to my public_html/cgi-bin/ folder. I have set my permissions to 755. The folder I upload has the following contents: junk Libs(folder), Resources(folder), .htaccess(file), config.cfg(file), junk(file), junk.cgi(file).

When I try to run the app I get an Internal Server Error.

“The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator at to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.”

Over the past few days I have spent hours on the phone with Godaddy tech support to no avail.

I am getting frustrated.

Something must have changed at GoDaddy. I uploaded a test web app some time ago that worked like a champ, but now I get the same error.

EXCEPT… I just recompiled and uploaded with the latest Xojo, and it works just fine. I didn’t really have to do anything special with permissions either, although some time ago I modified my .htaccess to include:

AddHandler fastcgi-script .fcgi

I put the entire folder into the html directory and call it with The actual link is:

Does any of this help?


Thanks for your suggestion.

I added “AddHandler fastcgi-script .fcgi” to the end of my .htaccess file and now I get the error:

“Unable to launch application ‘junk’ on port 9518”

It’s progress. It’s nice to see a new error!


Do you want to send me the source and build so I can try it in my account?

@Stuart Travis - make sure you are building for Linux. This looks strangely similar to the error you get when you try to launch an OS X build on Linux.

Just out of curiosity, you guys aren’t doing this on a shared hosting account, right? You’re using a GoDaddy VPS?

I’m on shared.

Shared will generally work but not for very long. Shared hosts do not like individual processes being fired up consuming RAM and CPU time which are quite precious when you have 1000 domains running on a single box.

VPS prices are very competitive these days so I’d recommend that in every circumstance.

For the record, so would I. We were just talking about testing.


Sorry I haven’t responded sooner. I was using shared hosting. Following the advice of Xojo Tech Support, I upgraded to a VPS account.

I am still unable to get anything to work. I have followed B. Keeney’s video from his website on deploying an app to VPS, but for me it is so short on details and it is not much help.

Following what I think B. Keeney is doing, I created a folder called “apps” at the same level as the “public_html” directory. I uploaded my “junk” folder to this “apps” folder. I also have added the line “Addhandler cgi-script .cgi” the the beginning of my .htaccess file.

I try to run junk by entering “”. This generates no errors and results in a Godaddy splash page.

I have also tried uploading the app to every other folder to no avail. I believe I have read every single line of information Xojo has on deploying apps 20 times.

And yes, I am building for linux.

Have you directed your domain to your server?

Yes, I have directed my domain to my server.

I haven’t personally used GoDaddy for anything, but are you sure you want https here? If you are getting a generic GoDaddy splash page that seems to imply something more fundamental is wrong.

Good catch, Paul, https will not work. It must be http.

[quote=51939:@Stuart Travis]I try to run junk by entering “”. This generates no errors and results in a Godaddy splash page.


Tried it with (https is not supported) but I do get an error 404 before the redirect to the GoDaddy splash. Meaning your files are not where they should be. Are you sure you posted your files to the proper cgi-bin directory ? On a VPS, the cgi-bin to your domain is not the same as the cgi-bin to your IP.

If this is true, it may be your problem. Nothing outside public_html is accessible from the internet.

Thanks everybody. Maybe we can eliminate one possibility.

In my build folder that I compiled for a linux operating system I have the following files and folders:
junk Libs

1.) Do I need to modify my .htaccess file with the following command: “AddHandler cgi-script .cgi”?
2.) What location on the server should each of my files and folder be uploaded to?
3.) Based on the answer to question 2, what would my redirect path look like?
4.) Do I need to change the port=0 to some other port in config.cfg?

The error 404 I saw says that the files are not where they are supposed to.

Why don’t you upload the files in the build folder to cgi-bin, so they will be accessible though :

You can use other folders later, but at least you know where the cgi-bin is because it exists already.

Thanks Michel.

To make sure, I need to create a folder at the same level as the public_html folder called cgi-bin and place all files in this location?