trying to compile existing program

Hi,

I tried to compile a desktop application that works under windows.
Building for Linux 32bits is no problem.
Building for Linux 64bits and Linux ARM32 gives an error
Location = Linking Executable
Issue = Failed to read binary: no such file or directory

Running Xojo on windows 8.2 64bits.

regards peter

That may indicate that your program contains a declare to a 32-bit library. You need to adapt your declares such to use 64-bit external libraries.

Hi,

But the Linux ARM is 32bits and also gives the error.
Besides, what external libraries would that be?

regards peter

Building for Linux 64bits and Linux ARM32 gives an error

doesn’t this mean you are trying to create a 64bit executable for a 32bit processor?
if so, an error makes sense…

The program is a desktop program that I normally use on windows.
32bits build executes on win8 64bits without issue,
but building 64bits fails.

I was just reading about the 64bits, it is considered beta at this time.
So only 32bits windows and Linux works (I did not test OS X),
but 32bits ARM Linux fails.

regards peter

I would check for declares.

And peruse the entirety of the 64BitReadMe.pdf in the documentation folder
There’s a long list of things it might be in there
Declares into a 32 bit lib from a 64 bit app
And there is a list of current known issues

If you end up stuck, post a project that demonstrates the problem (either here or in a private Feedback case) so we can try and help.

Peter, were you able to get this issue fixed?

I got the exact same error when I tried to compiled one of my big projects to Linux 64-bit for the first time.

I stumbled on a workaround:

Set the architecture to 64-bit, THEN FIRST SAVE THE PROJECT, and only then try to compile it.

Not sure if this workaround will work for your project, but it seemed to fix the issue for 2 of my projects, and it might be worth trying.

We get the same error here. We don’t use any declares. We are lucky: we have several Window/Linux PC’s and a couple of macs. The programs do compile on Mac. None of the new platforms compile on Windows.

If you have Beta access, I’d encourage you to test the latest there.

Hi Alwyn,

Doesn’t work for me. I posted a private feedback so I assume they are working on the issue.
One other thing, building for windows 32bits succeeds, but the generated .exe fails
to start on windows xp 32bits (some entry in a DLL cannot be found), but it starts
on win7 32bits but also throws an exception on exiting.
Building with xojo 2014r1 shows no issues at all and runs on both xp and 7.

regards peter

XP is not supported any longer
See http://developer.xojo.com/system-requirements

Goodbye, Windows XP.