Timer problem

Every time I reload my project in Xojo all Timer.runModes are set to Multiple, while they are initial set to Off in the Inspector.

Please fill a feedback case.

I tried, but the Feedback.app doesn’t give me the chance to submit.

Current Feedback version?
You searched for a case?
Found none, so created one?

I can’t simulate this with 2020R2.1 on macOS x86 Big Sur. Which version are you using? In case it is a bug on your machine, try setting the timer setting in an open event but again, I can’t reproduce it …

I just installed 2.1. I use Big Sur 11.0.1.
The problem is not solved.
Now I set the runModes in the Openings and Constructers as a workaround.

1 Like

Hi Christian,

Feedback version 2018r1.1
I searched a case and created one.
Submit stays grey…

Hi Herman, happy that this workaround is working for you. I think that it might then be related to your particular project. Could you please verify this by creating a new empty project, add a timer and save it. Does the same behavior occur, or does that work? For me it works in a complete new project but I just notice that your message in the iOS category. I tried it for a desktop app. It might be it is not working solely for iOS. But I suggest that you are testing this as well.

Yes, it is an iOS-project.

If I create a new iOS project everything behaves like expected. I add Timers and the runModes stay as set in the Inspector.
If I add a new Timer to an old iOS-project than the error occurs. I tested with 2 different old projects.

Are you sure this is a plain Timer or is this Xojo.Core.Timer?

This is definitely a problem the IDE has. I’ve had Label alignment get screwed up countless times while working exclusively in API 2.0 for Lifeboat.

I can’t figure out a pattern so I never made a ticket. It seems like it’s an issue with old values vs new ones, which baffled me in my API 2.0 only project.

1 Like

It is a plain Timer. Else no run modes.

What project type is this? Text, binary or xml?
With text projects you clearly see the ide changing values over and over again making lot’s of unwanted changes to the files itself.


Then you cant easily check what changed. Could be a bug with read/write in the ide loading of the actual project…

I am also getting this, even if I just drag a timer from the IDE onto a view, I cannot compile it as it throws errors about timer.mode / timer.rumodes timer / Xojo.core.timer I have timers that work which were imported from an older version of the IDE.

Wow, this may explain a LOT!