The Project/Run Remotely/Setup... menu is silent

On Windows 8, if I select the Project/Run Remotely/Setup… window either by mouse or keyboard nothing happens. Anyone experiencing this ?

That should open the Preferences window to the Debugging section, which is what it did when I just tried it on Windows 8.

Well, opening the preference menu with its dedicated menu works. But not with the Project/Run Remotely/Setup… menu. Xojo just sits there and nothing happens. The version I’m using on Windows 8 is the FC4. My understanding is that this the release that’s used as the final release. Am I right ?
Beside, I’ve been unable to remote debug between Windows 8 and Mac OS X 10.6.8 so far. The the stub running on the mac side is always giving me strange errors.

Yes, that is the version that was released.

I haven’t tried this recently (I usually go from OS X to Windows). Is it project-specific or does it happen every time?

After removing all RS & Xojo’s applications and reinstalling Xojo, everything works as a charm.