The dreaded ../../../../../../../../

Frequently if Xojo crashes. (And it crashed once a week for me). When I try to reload it On open I get the following bizarre path. Does anyone have a work around other than simply trashing the days work to that point and starting from a backup?

If the missing file still exists on disk, you may be able to edit the Xojo manifest with the right path.

If the file is ‘gone’, then maybe a timemachine backup.

In my experience the file is still there you just need to find it. I open the project file in a text editor and then see what file it is (assuming there’s any text shown) and then put the real path in through the text editor.

Another way I’ve fixed it is to ignore the error and compile and see what object is missing. Locate it on disk. Close the project and then reopen it. When the Locate dialog appears I know where it’s at.

Dumb ways to resolve it but it’s worked for me the few times I’ve had it happen.

2 Likes

One of the things that’s easy to forget is that dragging an item from the desktop into your project does not move the file on disk. What you’re seeing will usually occur when the file that was dragged in was then deleted.

Yep. This is what I have to do. Thanks Bob. Now if some can help me with the load timetime on the project. It is now about 10 minutes! (MacBook Pro M1)

Ouch. We’re switching to 2022 R1.1 because project load times are better for us. But we are desktop only.

1 Like

You do not disclose your data…
is your project:
XML or GIT ?
Stored on cloud ?
Stored in HDD, (with low empty space)
Have tons of large embedded images…

Have-you checked your hard disk with a HD Tool ?

etc.

At last, you may create new feature(s) in simple project, then when it is Rock Solid, include it in the project.
etc.