Textfield typing problem in Carbon app on Yosemite

We have a customer with a vertical market app. About 10% of their users that are running Yosemite experience a problem where they suddenly can no longer type in textfields. It takes about an hour of using the app before the problem appears and restarting the app solves the problem. It’s a carbon app. They are working hard to move it to Cocoa but that’s for their next big release.

If anyone is experiencing this issue, please let me know as I’m hoping to help this customer out with some kind of workaround for the time being. FWIW, this may not be a Xojo bug at all. It could be a bug with Carbon apps on Yosemite. But determining even that would be useful.

Have you seen https://forum.xojo.com/16850-typing-in-textboxes-sometimes-fails-in-yosemite-10-10 ?

Phillip is actually the user to which I was referring. I didn’t realize he had posted about it already.

We encounter exactly the same problem with our application (Carbon/Yosemite).

The Cocoa migration is underway but it’s long and complex (project 340.000 lines), in particular two brakes at the moment :

@Benoit Griveau Can you reliably reproduce this bug? Can you reproduce it in a small project? Either of these would be very helpful in terms of fixing it.

I have not been able to reproduce with a smaller application.
I suspect that this happens on memory-intensive applications.

Another problem in the same circumstances : drag and drop (listbox to listbox) unresponsive.

I looked in Console and Activity Monitor but I do not see anything special.

Bug Yosemite ?..

That seems likely to me but we have so little information at this point it’s difficult to say.

I have a customer reporting a crash in 10.10 with my REALsoftware-built Carbon app:

Since the window at this point consists of just a dialog sheet, a text field, and OK/Cancel buttons, I wonder if this could be the same issue?

Oddly, although this is a Mac App Store app, I’m not seeing any crash reports in iTunesConnect.apple.com

Has there been any progress on this?

My experience is slightly different. I have an application that when you launch it and click on any text fields or text areas, no text insertion cursor is displayed, nothing at all actually, nothing blinking, it looks like blocked. If you already have text in the field and click anywhere, you never know where the insertion point is until you actually type something. Now, as soon as you open a dialog above the window and close it, everything gets fixed, your see the insertion point correctly blinking in all text fields and text areas, even if you create a new document. Opening that dialog is what the application needs since everything work until you relaunch. This problem starts with Yosemite. I tried different versions of my app built with RB and Xojo. Same result. Hope that helps!

[quote=156874:@Michael Diehr]I have a customer reporting a crash in 10.10 with my REALsoftware-built Carbon app:

It turns out my crash was in a background thread, and is thus most likely not related to this textfield/carbon issue.

These all sound related. If any of you can reduce this to a simple project that reproduces the problem, that would be of great help.