Textarea & dash dash

I’ve ported an application from Windows to Mac (Yosemite) and surprisingly I’ve seen that when I write dash dash “–” in a TextArea automatically it changes to “—”.
It doesn’t happen on Windows and I don’t want this to happen.
Is it a way to prevent this behaviour?

Thanks

In System Preferences, select the Keyboard preference pane, then the Text tab. On there, uncheck “Use smart quotes and dashes”. You’ll probably have to restart the app for it to take effect.

Great! Thanks Paul.

I too thank you. I have expressed an exclamation or two a number of times when consecutive dashes have turned to solid lines but have never taken the time to figure out how to fix it. Having read this, it is now fixed. Always ticked me off but just not quite enough to get me to do the research.