TaskManager Tutorial Deployment

I have followed the tutorial on web development and tested / uploaded the taskmanager application.


However, when I run it, I get the following error:
Unable to launch application ‘TaskManager’ on port 19720

Where is the port set in the Application and what port should I use.

Thanks for your support!

The port is usually set automatically and you don’t have to worry about it. Your problem could be as simple as not having the permissions set properly or the host computer may not be set up properly. My first VPS account was with DreamHost and I frequently got the same error you are seeing. Eventually I got tired of it and got a new VPS account at HardHatHosting. The only time I see that message now is when I forget to set the permissions after uploading a new app.

There are other possibilities:

  • Missing 32-bit libraries
  • Missing application identifier
  • compiled for Wrong platform (compiled for Mac, uploaded to Linux )
  • Missing Libs folder

Are you able to launch the executable from a command line and see if it returns any errors?

Another possibility is that the files are owned by the wrong user.
On my VPS I have to chown apache:apache nameofthefolderwhereiuploademyxojofiles -R

Also don’t forget to mark the executable and the cgi as executable
cdmod 755 executablefilename
chmod 755 cgifilename

Thanks. It’s due to missing 32-bit Libraries. I uploaded this to a site running on Amazon Cloud and it’s running 64-bit. This is the error when I run it directly at command line:

TaskManager: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory

I uploaded it to a site hosted by hostagator and it works fine.