Suddenly stop running?

Hello all,

This is really weird. Suddenly a stand-alone web app, that runs on port 8080 will appear to start running when clicked but when I check the Task Manager, the app does not show up. It did previously. There have been no updates to the pi. Another app, which is a console app does run and does show up in the task manager. I checked file permissions, rebooted, and tried to find the system log files, but could not. None of the application log files appear (they did before when errors occured such as database, or other tracked items). However, the console app does have all of its log files appearing.

What is really strange is that this was very spontaneous. However, no updates of Xojo, or any of its components. I have reset all of the permissions on the pi and have checked the Sqlite database permissions as well.

Has anyone seen anything like this? Could this be a problem with the micro SD card? Any ideas would be really appreciated.


Do you get anything different if you start it from the command line?

Hi Bob.
No, no difference when starting from command line. Even using sudo as part of the command.

Did you try our SignalMBS class?
You could use it to catch various signals.

Thanks for the replies everyone!
I think it was a problem with the SD Card - but not 100% sure. I recall seeing a different error showing in my browser when I tried to use it yesterday. It could very well have been hacked since I had it on the DMZ and stupidly had not changed the login or pw for the pi…

I did check the SD Card and could not find any virus on it, but that doesn’t mean that it wasn’t there. It has been erased and is running now.


I know that I ended up replacing the SD card in my original Pi. I put in a significantly larger one and I’ve not had issues since.