string split not working right sometimes


i have a tcp socket that get webpage source code and i use split to separate values like

split(“blizzard, StarCraft : Remastered,Logiciels”,",")
StarCraft : Remastered

which is correct
but in some cases, same code,i have one, it gives
split(“Immobilier, Rsidence secondaire, Immobilier”,",")

Rsidence secondair
, Immobilier

so there is one caractrer missing on second value, and it returns a coma in the third one !??

Is this 64-bit Mac?


there are other differences between both examples.[quote=338400:@jean-philippe peugeot]split(“Immobilier, Résidence secondaire, Immobilier”,",")[/quote]
In that case, the delimiter have to be ', ’ (comma plus a space).

Also, in that example, the text is UTF-8 (the e acute; e accent aigu): this is a usual suspect.

BTW: this second example works fine here (Xojo 2015r1 / El Capitan 10.12.5).

What Xojo version / OS Version are-you using ?

yes it was in 64 bits!, when i try the same in 32 bits it’s fine !

xojo latest mac.

details :

of course i tried to reproduce in a separate files, but when i give the string from a var, not a tcp socket it works…
if found a another worst example :
Actualit conomique, entreprises, conomie, bourse, emploi, impts, cac 40, creation d’entreprise, chef d’entreprise, grands patrons, consommation, multinationales, privatisation, dlocalisations, concurrence, monopole, crise, bourse, licenciements, union europenne, etats-unis, chine, pmi, pme, tpe, salaires, relance, pib, pnb, aides sociales, japon, rcession, conomie verte, fmi, reprise, croissance, news, actu

becomes in a array :

Actualit conomiq
e, entrepris
s, cono
ie, bou
se, emp
oi, imp
?ts, ca
40, creation d’entrep
ise, chef d’entrep
ise, grands pat
ons, consomma
ion, multination
les, privatisa
ion, dlocalisa
ions, concur
ence, mon
rise, b
urse, licencie
ents, union europ
?enne, etat
, pm
, pm
, tpe, sa
aires, r
, pi
, pnb, aides so
japon, r
ession, conom
e ve
te, fmi,
reprise, cr
e, news, actu

if i tried in 32 bits it works fine !

[quote=338429:@jean-philippe peugeot]yes it was in 64 bits!, when i try the same in 32 bits it’s fine !
xojo latest mac.
if i tried in 32 bits it works fine ![/quote]
There is a known issue with 64 bit and splitting strings for the current public release of 2017r1.1
Please remember that 64 bit is still considered in beta.

maybe i don’t need to code in 64bits yet ?? just wondering. or i search an SplitMBS :wink:

64bit issues with Split have been well documented elsewhere on this forum

Well the best way to get 64 bit out of beta is to help find the bugs; so the split issue aside, working in 64 bit is helpful to the engineers at Xojo. I wouldn’t deliver a 64 bit build to a customer though (I tried with Answers and the Split issues bit me).

ok i found one thread about split being slow on 64bits, well it doesn’t work, i’ll switch back for dev to 32 bits for now, whille testing once in a while in 64 bits of cours
thanks all for insights

Using String.Split or Text.Split ?