Strange behaviours (El Capitan)

Hi all,

this is the second time in some days (less than a month) that I saw some strange behavior with a compiled application (two different ones):

a. Sometimes ago, a csv file was loaded bonkers:
the first lines were loaded correctly, then I get Returns everywhere, in different places (between columns, where they are not, IMHO).
I was supposing that the file became bad (for unknow reason) and so I loaded it with TexEdit, change it to rtf (so I can use \Tabs for alignments), and started to make it correctly aligned.
Then I noticed that I was working on the original file, not a copy. I discarded the changes, set a copy, started to align the data until I had a strange idea:
using QuickLook (another time) to be sure the error is in the csv file, not in my application (since this happens, sometimes).
The display was correct, 100% correct. Then I loaded it into my application and it was correctly displayed.

b. earlier today:
In an application where I download an html file, seek into it for a specific image, then download that image, the process blocked at image save time. And I wrote the fast way (skip all details).
I tried different URLs (same web server), checked directly with Firefox (the “decrypted“ image URL) and there, the image appears :(.
After a while, I had enough and remove the external hard disk.
Then, I was asking myself: what if for some reason, that hard disk (or the target folder: the folder where I store the downloaded image in) does not have write permissions ?
I connected / mounted the external HD, open that folder, create a new folder in it without trouble. I then fired the application, ask for downloading some images files and it does that for the two first images, then stopped with my “end of download string report”. (same as previous).
I tried to create a new folder and this was refused. My next attemps tells me that the hard disk is full (it have >35GB of free rooms…).

Question:
In the recent Years / Months / Days, did you suffer from this kind of strange things ?

Environment
MacBook Pro 13" Retina (3 years old model), 8GB, SSD,
El Capitan,
Xojo 2015r1 generated stand alone (generated on 2017-11-25, before a major bug).

Late Breaking News:

a. It is the other external HD that have nearly 40GB of free space, not this one (around 540MB of free rooms only).

b. I am virused (!): the project folder, once opened suffered from a Sort alphabetically * (view by Icons): none (or so) of my icons are anymore at their previous location.

It may be time to retire (before I came 100% crazy)… :frowning:

Edit:

  • Or the invisible macos file was deleted, rebuild, losting the previous properties.

And now the application works (same application, same locations, …) !