Standalone WebApp suddenly stops accepting requests SSL?

Hi all,

For some reason, a new app I put on my intranet here will suddenly stop accepting remote requests - I can still access the app from my local system using the IP ( address (I tested via localhost and that worked too) as well as via a VM guest on the same host (separate IP ( address bridged to the adapter, not a host only network and not NAT’d - this was to test if it was a Windows specific issue as I normally use a Mac). It was even working on my workstation (where the standalone sits) this morning, but one of my co-workers couldn’t access it and I couldn’t seem to access it from a workstation completely separate from mine.

I stopped the process (I have it running as a daemon) and re-started it with more SSL connections (upped to 300, I don’t know what the default is - couldn’t find that info on the Xojo doc site) and it’s working again for other systems on the network but I’m concerned that it would stop responding to remote requests for no good reason but be still running… Any thoughts?

I’m having weird connections issues as well but it’s browser specific. The reason I wonder if it’s similar to what you are seeing is that I’m getting different results on WAN vs LAN - making me wonder if there is some weird NAT thing going on? See

What version of Xojo are you using? I feel like my problems started when I upgraded to a 64 bit build on macOS using Xojo 2017R3. (Of course, this could also be due to changes in browsers as well).

So far in my case, it’s all local Lan (no nat), once it stops working for clients on the network that is not my workstation, it won’t work in any browser I’ve had available to test (IE 11, chrome, FF) UNLESS it’s on my local computer where the standalone web app is running where it will work in Safari, Chrome and FF. I’m currently using 2016 r4.1, I do have 2017 r2.1 installed on my laptop, but I hadn’t tried it on that. I’m currently building the webapp as 32bit, but was considering changing it to 64bit if the issue continued to see if there was a difference.

I also noticed another weird thing that I’ll probably post about at some point is that it seems that clicks on modal dialog boxes can traverse to controls in the underlying page (like you click on a button on a dialog box and that button of that dialog happens to be on top of a listbox, the listbox will fire the change selection event; this may be a chrome specific thing (which is my primary test platform) or across the board, I haven’t tested it extensively)

Thanks Tony - other than us both using standalone SSL webApps, it doesn’t sound like we are hitting the same issue.

I’ve found it’s not just the TLS port, but also the regular port no longer accepts connections as well and I don’t see any logs to describe what is going on :frowning:

I did find the problem - part of it understandable, part not quite so sure.

It appears my problem was after I had updated the Mac this runs on to High Sierra, my sleep settings were reset so the computer was going to sleep. Obviously when the computer is asleep it won’t respond :wink:

Now the two parts that are confusing me - the Mac was set to wake on LAN events - yet it was never waking - and the next part - after I would wake the computer up, that is when I could access it locally but one could still not access it remotely (on the same LAN) until after I exited and re-launched the application which makes it feel like it’s an issue with the built in web server in how it handles sleep/wake scenarios.

Needless to say, I have it no longer sleeping so that has solved my primary issue for now.

Wake on LAN doesn’t mean that it’ll wake up whenever something tries to connect. It’s a special packet that can be broadcast on the network which the NIC looks for. If it receives one for your particular computer, the NIC tells your computer to WAKE UP!!!