Stand Alone Web App Crashes - Faulting MSVCR120.dll, v: 12.0.21005.1

I have a very simple Stand Alone Web App that is constantly crashing due to MSVCR120.dll. The Application Log on the server always looks similar to the following:

Faulting application name: MySQLDBWS.exe, version:, time stamp: 0x56214be6 Faulting module name: MSVCR120.dll, version: 12.0.21005.1, time stamp: 0x524f7ce6 Exception code: 0x40000015 Fault offset: 0x000a7676 Faulting process id: 0xa18 Faulting application start time: 0x01d12242b7f6dbd1 Faulting application path: C:\\Program Files (x86)\\MySQLDBWS\\MySQLDBWS.exe Faulting module path: C:\\Program Files (x86)\\MySQLDBWS\\MySQLDBWS Libs\\MSVCR120.dll Report Id: b816a921-8e38-11e5-b2d5-005056bc01cd

The web app acts only as a web service using HandleSpecialURL to Insert/Update via Post and Query via Get to a MySQL Database. It is a 32bit app running on Windows Server 2008 R2 64bit installed as a standalone web app on port 8080. MySQL is also installed on the same server. All code executes in App because I’m only using HandleSpecialURL. There is no session code. The app uses methods for each special URL, makes a DB connection, performs the service request and then closes the MySQL DB connection then returns the result. Other than the crashing due to the DLL it works beautifully for my purposes.

Anyone have any suggestions on what to do to fix this?
(I did try a 64bit compile but the MySQL plugin 64 Bit version apparently uses old password security and the DB returns an old passwords error.)

Nobody? Hello… Is this thing on?

The MSVCR120.dll file doesn’t belong in the Libs directory. Recompile your app and copy it as-is without moving any files around.
Sorry, I thought you were compiling for 64-bit.

What version of Xojo are you compiling with?

The version that I compiled with when I posted this was 2015 r3. Yesterday I downloaded r3.1 and compiled a new executable and replaced the existing standalone but have not had the opportunity to test extensively yet.

I would compile it 64 bit if I didn’t have to change the db to use old passwords and lower the security. The 32 bit version works without any db modifications.

Since there has been no further response or advice, does this bug have a work around? I’m dead in the water until I have a resolution for this crashing DLL.

Just in case this is something in my code causing the DLL to crash here is a link to my project. MySQLDBWebService

The Web service allows the user to insert or update data in any MySQL database via a POST and query data via a GET as long as the service is running on the same host as the MySQL DB. (You would have to update the DB prefs in the service to run it on a separate server.)

One possibility is a corruption of the file.

Perhaps this will help.

Have you tried logging methods in your code or debugging to see where the problem occurs. I’ve downloaded and glanced at the code, and I see some things that you might want to change, but I couldn’t say if any of that is the cause of a crash in a particular DLL.

Under what conditions does it crash? A particular call to the web service from a client, or it crashes before you can get that far?

I’ve tried some limited logging but I haven’t observed pattern to what makes the DLL crash and didn’t log anything revealing. It works from 1 to several times with any of the special URLs and then the app just dies.

If you have any suggestions I’m open to make changes and test.

I tryed to compile my windows standalone webapp with 2015r4 and it crashes after less than minute of use.
I tryed to build 64-bit and 32-bit, both crash. I run it in Windows Server 2008 R2 (64-bit).
I debug it with 32bit windows 7 machine and there it works fine.

I then built it again with 2015r2.1 and it works fine on server also.

This is from 32-bit version crash:

Faulting application name: wwstat.exe, version:, time stamp: 0x56711ed7 Faulting module name: MSSQLServerPlugin.dll, version:, time stamp: 0x56711f1e Exception code: 0xc0000005 Fault offset: 0x0000f861 Faulting process id: 0x13d4 Faulting application start time: 0x01d138cc80cd682f Faulting application path: c:\\xojo\\wwstat\\wwstat.exe Faulting module path: c:\\xojo\\wwstat\\wwstat Libs\\MSSQLServerPlugin.dll Report Id: b2139d72-a54c-11e5-94ba-005056bc5551

And this is from 64-bit version crash:

Faulting application name: wwstat.exe, version:, time stamp: 0x00000000 Faulting module name: ntdll.dll, version: 6.1.7601.19045, time stamp: 0x56259295 Exception code: 0xc0000374 Fault offset: 0x00000000000bffc2 Faulting process id: 0x370 Faulting application start time: 0x01d138cbfeec1096 Faulting application path: c:\\xojo\\wwstat\\wwstat.exe Faulting module path: C:\\WINDOWS\\SYSTEM32\ tdll.dll Report Id: 4a993d3b-a4bf-11e5-94ba-005056bc5551

BTW. I also built one console app that runs on that same server. I t works fine on 64-bit.
It uses MSSQLServer plugin and MYSQLCommunityServer plugin also.


Thanks for the input Jukka. I just downloaded 2015R4. I hope to do a rebuild and test my app in the next day or so. I’m hoping that the MySQL security fix and 64 bit will make this problem I experienced go away.

I’d recommend you enable user-mode dumps via the registry and file a bug report with the crash dump created when your app dies.

I have dumps of both crash. I’ll try to do that…