Stand alone App on Linux/Pi wont run?

Hello all,

I had made some changes to my web app with regard to its forms and interactions with the SQLite database. It compiles fine on Windows and runs as expected in a windows environment - same as many times before.

Copied the folders/files from the my windows machine to a dedicated Linux machine so I could compile to linux/ARM. For some reason, this particular app will NOT compile on a windows platform for Linux or Linux ARM target.

The project compiled fine, but twice I had to set the Xojo licenses. That was strange. First time was yesterday 8/5 then again today 8/6. The computer had been on for days prior but not used. Between 8/5 and 8/6 on and xojo was running (I think, not 100% sure). When I went to open the project tonite with last nights work included, I had to go to the Xojo website and remove the Linux machine I was working with, than re-add it. I also had to do this Friday 8/4 when I brought that PC home to work with this weekend. It seemed strange and annoying but not overly so - I mention it just in case it has relevance to those who may be in the know!

At this point, I can compile fine. I uploaded to the target Pi, but when told to run via VNC, it does not. It is not show up in the task manager. I also does not show up in any of the following log files:


I also checked several other log files. All log files checked using webmin. NONE showed anything to do with the app name.

A note that * may* be of importance, is that I did update the OS 8/4/17. I think there were 42 updated files to be performed.

Bottom line, an updated Console app, which also uses external/shared files that the Stand Alone Web App uses, runs perfectly fine.

Any ideas would be greatly appreciated!
Thank you!


How are you running it? Command line? Any messages there? Does it just return immediately?

What port are you using? It is available on the Pi? Are you using a low port and maybe need to start the app with sudo?

Does a simple standalone web app (say with just a button) work?

Hi Paul.
I launch it by double clicking on the executable, then the OS asks if I want to execute, execute in terminal or cancel - I just execute. This is the same method always used in the past.

There are no msgs at all. The task manager does not show it running at all - before it always did.
Checked the system logs, nothing.

None of my error handling captures anything.
I am thinking maybe permissions issue? The ownership is pi, group pi. The permissions for all folders except the path to the database is 0775. The permissions to the folders to the database is 0777.


You should definitely try running it from the Terminal that way you may get error messages that might help you figure this out.

To run it from the terming, just change directory, then type the name of the executable AxcysEmbeddedViewer in this case - correct?

Hi Paul,

OK - got something I think. I get an error “Segmentation Fault” printed on the console screen.
How do I identify the culprit and correct?

I don’t get any errors in Windows or Linux on x86.


@Tim Seyfarth
Hi Tim,

Here are some instructions to help run the program:

  1. open a terminal and make the active directory the same as your executable
  2. Give the executable the propert permission by typing:
sudo chmod +x /home/pi/desktop/MyPiProgram

MyPiProgram is located on your desktop
3) Run the program with the following command

sudo /home/pi/desktop/MyPiProgram

Does this work for you?

Hi Eugene.

Thanks for your reply!

I got it to try to run- changed directory.
Then ./AxcysEmbeddedViewer
Got the Segmentation fault error…

pi@AxcysEmbeddedController:~ $ cd /home/pi/Public/axcys/AxcysEmbeddedViewer
pi@AxcysEmbeddedController:~/Public/axcys/AxcysEmbeddedViewer $ ./AxcysEmbeddedViewer
Segmentation fault
pi@AxcysEmbeddedController:~/Public/axcys/AxcysEmbeddedViewer $

Hi Tim,

There are a couple of things that this may be:

  1. The executable and libraries are in a folder that does not have permission to run. Try and make a new file folder on your Desktop for the install file and supporting libraries and try to run it there.

  2. Is the system OS updated to the latest version?

  3. Is the firmware updated to the latest version?

  4. Make a simple “Hello World” program and see if this works.

  5. I am taking a guess at this, and there is a possibility that the file system might be corrupt (many discussions on Raspberry Pi forums mention this). If you have another SD disk then try a fresh install of Raspberry Pi - I would try the above options first.

Hi Eugene,

An older version (like a week older) worked fine. I had made several changes to it mostly to create a database if none existed. Ive tried it both the just released rasbian updates and with the one just behind it. Both the same. Tried with all permissions set to 777, no change. Tried with and without the database, no difference.

And it does not show up in any of the system logs as a crash, runing nothing… so strange!

Sorry Tim,

I don’t know what to say. Try an older working version and slowly add code while trying to run it at various steps on the Pi.

It does sound strange.

You’ve checked nothing else is using the port? I’ve seen standalone apps silently quit if the port binding couldn’t happen.

Hi Wayne,
How can I check the port? There should not be anything else, but who knows - port = 8080

What about SQlite database versions? Since this one is being created by the app, it will be a version higher than the last one. The console app that accompanies this web app works fine - it appears

I did add code tonite to write to the system debug log

System.DebugLog( "starting: " + CurrentMethodName  + " no error type available" )

I put it in the app start up section to see if it is really starting. This is a PIA but it may show where the failure is… eventually.

Thanks for the ideas everyone!

netstat --listening --numeric
will show you. Any chance the previous version is still running (or started automatically)? You could just try a different port perhaps 8081.

No, its been overwritten and/or deleted. I typically restart or shut down the pi first. In this case, I deleted the folder and created a new set of folders.

I also tried the new compiled version on a working SD card. It failed. Tried with different OS versions too. One was the just released version the other released not long ago.

But changing the port is quick and easy - will do!

Thanks Wayne

I still cannot get this thing to do anything. I adding print code to the, app.close, app.un

This is from the auth.log

In the syslog

I think it is closing the session by itself. I just tried again and the auth.log shows

Nothing is shown on the Console:

Any ideas??

Thanks again for the time everyone!