SSL behind a firewall

I have an app that uses MBS CURL in SSL mode to upload a file to my server. It works fine everywhere so far except when I am in my corporate office behind a firewall it doesn’t work. Is there anything obvious I can do to address this?

Does your server have a real cert or a self-signed cert? Is it possible your corporate network requires proxying web requests and your app is not going through the proxy?

turn on option verbose and see debug messages.
What does it tell you exactly?

Could it be that they need to open a port?

I suspected that may be an issue - I am self-signed at the moment.

[quote=174007:@Christian Schmitz]turn on option verbose and see debug messages.
What does it tell you exactly?

Could it be that they need to open a port?[/quote]
OK - I will get to that later - not time at the moment. What I no at the moment is error code 35.

The corporate firewall may need a rule that allows the ports used by MBS Curl.

Here is the last bit of info from the verbose messages - everything before looks OK - I believe. Does this help explain what the issue is?

Reminder - this works OK when not in my corporate office. This is what I see when in the office …

SSLv3, TLS handshake, Client hello (1):
[9720] Debug message, infotypr 6: [
[9720] Debug message, infotypr 0: Unknown SSL protocol error in connection to jomark.com:21
[9720] Debug message, infotypr 0: Closing connection 0
[9720] Debug message, infotypr 0: SSLv3, TLS alert, Client hello (1):
[9720] Debug message, infotypr 6: [
[9720] Upload result: error code: 35

Interesting - I just tried it again and the file transferred successfully!

And then tried it again and it failed, again.

Any thoughts?

sounds like random failures?
Do you use TLS in which version?
Does log show more?

[quote=174182:@Christian Schmitz]sounds like random failures?
Do you use TLS in which version?
Does log show more?[/quote]
I will send you a private message with more info - as there may be more info than I care to share publicly.

Got it. Thanks.