SQLiteDatabase DatabaseRow Real column limited?

I’m struggling to figure this out and may have looked over the obvious so I’m bouncing it off this group…

Using the latest release of Xojo and compiling for iOS, if I try to set the double value of a column in a DatabaseRow to a large number like “1628042614.3371000289916992” it simply sets nothing. A smaller number works.

I’m also doing the same in a web project (same exact number) and the SQLite database accepts it there.

I’m assuming this is a Xojo bug and I will file it as such, but I want to make sure I’m not overlooking something (in my exhausted state).

It would be helpful to see some code

var rec as new DatabaseRecord

rec.Column(“theid”) = 1628042614.3371000289916992

It’s really that simple.
I’ve tried setting rec.column(“theid”).DoubleValue
I’ve tried casting it to a variant and then setting it.

and you can see that it’s not taking if you look at the Rec variable in the ide, if you try to set another variable to its value, or if you query the database after addRow.
I’ve done a second line after where i issue an update statement and it takes there.

drop this in a button in a iOS project

Var d As New SQLiteDatabase
d.ExecuteSQL(“create table test (theid real, context integer, a real, b real, c integer);”)

Var t As datetime = datetime.now

Var r As New DatabaseRow
r.Column(“theid”) = t.SecondsFrom1970
r.Column(“context”) = 0
r.Column(“a”) = 2.222
r.Column(“b”) = 9999.9999999
r.Column(“c”) = 1


Then look at r in the inspector.