SpecialFolder.ApplicationData suddenly points to a "TEMP" user....?

Out of the blue today I’ve had 4 phone calls from users what report our software suddenly has none of their data in it any longer. I have only been able to remotely log into 1 customer computer to investigate, and I found that though the user who was logged into the computer at the time had a username of “DrTom”, calls by our software to SpecialFolder.ApplicationData are now hitting “c:\Users\TEMP\AppData\Roaming” instead of “C:\Users\DrTom\AppData\Roaming”.

This specific user was on Windows Vista, and had all the latest service packs installed. All the users I’ve spoken with report that they shut down our software on Friday afternoon when things were working fine, and when starting it up today suddenly all their data was gone, with no changes to their systems or other installed software of which they are aware.

Anyone else seeing anything similar?

Sounds like the users may be getting temporary profiles. I would first look at the Domain Controller syslogs, and internal DNS. Check if any updates have been applied on the DC. Restart the DC if possible, then the clients. Try logging in to a client PC with an affected user’s account and see if you’re getting any profile warnings upon login. Check that client PCs are pointing to the correct internal DNS nameserver.

This might offer some clues to either resolve it, or eliminate AD issues.

Seems VERY odd that this would happen to 4 separate users in 4 separated geographic locations, on machines that are completely unrelated to each other. My users are acupuncturists and chiropractors spread out throughout the world, and they just go to the local computer store and buy the cheapest thing available, usually…There is not likely to be any domain controller on their network (other than whatever default a standalone windows box has).

What should the “correct” internal DNS nameserver be? Just whatever their DHCP connections offers?

Just got off the phone with another one - when I asked if they had any sort of Windows Server in their office his response was “well, we have a belkin that is wireless, and the 2 computers just share data that way.” So - that’s the type of sophistication of users we’re dealing with here…

Yes. You should not change users DNS settings. That won’t affect the user under which appdata points.

Are you sure they didn’t come up in safe mode? That would get you the TEMP user.

Sounds like a bad update may have caused the profile to not load correctly. When this happens the system creates a new temporary profile and keeps the other one safe. When fixing this in the past the trick is to recreate the user and copy the profile data over.

This assumes that they don’t have user profiles encrypted:

  1. Log in as an administrative user.
  2. Recreate the user name and password.
  3. Take note of the new user directory. It often will have a .001 after it.
  4. Copy the user data from the old user directory to the new user directory.
  5. Reboot and try logging in as the user.

Please note that I would not try the steps above remotely and they are really out of scope for application support.

OK, that eliminates a whole lot of possibilities related to a domain environment.

Whatever worked before. In a domain setup, DNS settings take on more significance and are a common source of these types of problems. Not applicable here though.

As I said before, it does sound like the users are being assigned temporary profiles. One way to test if this is the case is to have the user log on and create a text file, say call it “deleteme.txt”, on their desktop. Have them log out, reboot the PC, and then log back in. If the text file has disappeared then you can be pretty sure they’ve been assigned a temporary profile (which is deleted each reboot).

Like Bob said, this would be a systems issue, not an application one. I’d work with the client’s IT tech to recover your application data. The tech will have his/her own procedures for resolving the systems profile issue.

If you want to bone up on the issue, here’s a Google link. It’s actually a fairly common occurrence. (Maybe the users got nailed by the Windows 10 stealth update from MS )

Good luck.

Thanks for all the advice - The users I’ve spoken to report that every time they reboot they get a new desktop and all their stuff has disappeared (not just our app data) so I’ve gotten their data from our app safely off their machine onto a thumb drive and they are taking the computer in for an enema.

That made my day. Thank you.

On OS X 10.10.5 / Xojo 2015r1 (application), I get the same:

sometimes, at save time, I saw that I am in the Temporary Folder… SOMETIMES. And sometimes, this arise more than one time (for at least two different files).

I do not took time to investigate, and tried to remember to check where I save my data before hitting the Return key (stop be confident on where the file will be saved).

Are-we only two persons to get that on the whole community ?

I’ve never seen this on OS X, Emile.

I will try to watch more at save time (slow down the tests at save time) with that project and eventually report if I found something.

Getting the Temporary Folder as the default directory !

I will investigate later for what code I use to save the file (the code for the given FolderItem).

I just get it once more ON OS X 10.10.5 / application compiled with 2015r1.

And it was not the first time: there already was an older file (saved two hours ago).

The hardware:

MacBook Pro 15" Retina, 2014-12 - 8GB RAM - 256MB SSD
External Hard Disk connected (and it was the original load location of the currently modified data / where I was meant to save)

The Software:

VLC 2.15 was open (I was hearing music while using the computer).
TextEdit was open and used
Safari (last one, updated yesterday ?) was open and used
Preview was open.
My project running as a standalone application (I have to use it to better test it).
QuickView (used to “display” jpg, png, txt, html, mp3 files)…

Xojo project:

The code used to save the file (what the code was doing at this time)
[after loading Xojo and the project]
OK: I used SaveAsDialog.
I also set the InitialDirectory, so in a way, it can be my fault (at use time, not code time), but how ?

If mFileIO.gImportFI = Nil Then Export_CSV_Dlg.InitialDirectory = GetFolderItem("") Else Export_CSV_Dlg.InitialDirectory = mFileIO.gImportFI End If

The code is meant to open the SaveAsDialog into the folder from where I open the file. **

Note that I just checked the Import method to be sure of what I’ve done there and this is exactly what I wrote in the line above.

I hope this will help to find what happens.


PS: 4 hours of freedom, doing non intensive brain work (collecting data, copy / paste them in a ListBox) allows me to recall what’s in the note below.

  • Nota: I already get strange things, certainly because of the OS, years ago. The default directory was one used at some time in the past (but I do not know when). The wrong default directory was not always the same (I think / unsure).
    That project was created 14 years ago with REALbasic and is not related to the current one (except that it was created by me; but I do not own these hard disks at the time).

** I certainly already do that in the old application. (read * above)

When I woke up earlier today, my MacBook Pro was on sleep (too).

When I finished with the unsaved document, I saved it (using the same application as in my yesterday’s coontribution.

I noticed that the SaveAs Dialog opened in the Temporary Folder.