SmartScreen blocked Xojo

Alright, so when I was first gonna install Xojo, SmartScreen said “This app may put your PC at risk” I kinda don’t know what I should do? Is it safe to open? Is it a bug?

You downloaded from website?

Then it may be right, but Microsoft smart screen may not know this installer.

I got it at

So. yes. It is not malware, whats the problem?

Hi @Eurijah_Conway

If you downloaded Xojo from just go ahead and let Windows know that you want to execute the installer. Sometimes Windows its too much cautious I think :wink:


If Xojo is not using the best possible (and moste expensive certificate), Windows need first a certain amount of downloads until it will acknowledge that this particular version is safe. As the exe is changing whith each and every release it is normal. You can click to get more information and there you should see that the installere was signed by Xojo Inc. Then you are are good to go.

Update: same will happen, when you are distrubting your own apps … :frowning:

How do I execute the installer to get X O J O?

Tell Windows you want to run the installer anyway. It’s probably in your downloads folder.

1 Like
1 Like

Alright, but where do i go to let Windows run the downloader?

There should be something that looks like a link (text with underline) akin to the phrasing “More Information” which will make a “Run Anyway” button appear.

Huh, I dont see the Run Anyways button

According to the screen shot in the article earlier in the thread, you click the blue “Learn more” link to get another dialog with that choice.

1 Like

I just checked on my test machine, it’s “More info” there.

Messages Image(2250752357)


Dont see it…


When I go in settings, I dont see it… Maybe outdated

Can you uninstall SmartScreen?

I do not want to uninstall SmartScreen.

Check out the article that Thom linked, it suggests your security settings are why the button isn’t available.