Simulator Version 11.2.1 issue

I had my iOS app working fine with Xcode 11.2, but then foolishly allowed it to update and ‘fix bugs’
Now when I compile and view my app, I get a blank screen with the date and time and battery symbol upside down on the bottom of the screen, and none of my windows opening. I have tried different simulations of iPhones, checked Xcode preferences for locations and components, but cannot work out what I have done or should do.
I even download the Xcode command line tools from the developer site and reinstalled them.
Should I delete the /Applications/ directory and start again?
Any help or advice would be appreciated.
Thanks in advance.

Figured it out. It is not a good idea to turn off the supported orientations for the iPhone and then accidentally force it to show one of the no longer working. orientations.
Once I went back the the iPhone screen setup and turnedon the orientations, everything worked again.

@Philip Cumpston
Do you have several Xcode versions installed? If yes, did you check

xcode-select -p

shows to the Xcode version you want to use?

If not you can update the path e.g.

xcode-select -s /Applications/ --switch /Applications/