Setting filetypes in GetOpenFolderItem does not limit file types selectable?

You must install Feedback that you can download from in the extras area.

Thanks Michel.

Man, still doesn’t work. What the heck am I doing wrong!?

I happen to be trying to get OpenFolderItem to select only .ttf, .otf and .ttc fonts under 2015R4.1.

I first entered all the details for .otf from

then added all available details for .ttf and .ttc. The dialog showed only .otf.

Then I removed .otf, and when only .ttf and .ttc is there, no filtering takes place, everything is enabled : zip, txt, whatever.

GetOpenDialog is simply wonky.

I will now stop wasting time, set the file type special/any ???, and filter the result after selection.

Sounds like it’s broken on OS X. Maybe use an OpenDialog instead. GetOpenFolderItem is a shortcut that does have it’s own set of limitations.

I strongly suspect a Cocoa bug.

When I select “text/plain” the filtering works:

Name = “text/plain”, object name = “TextPlain”, Suffix = “.txt”, MAC-Type = “TEXT”, MAC-Creator = “???”

selecting it this way works:

File = GetOpenFolderItem("text/plain")

This way nothing is available:

File = GetOpenFolderItem("TextPlain")

applying it to my own style makes all files available:
Name = “database/rsd”, object name = “RealstudioDatabase”, Suffix = “.rsd”, MAC-Type = “???”, MAC-Creator = “???”

File = GetOpenFolderItem("database/rsd")

YESS!! With openDialog it works. Thanks Tim!

Did you tried .sqlite as file extension ?