Setting a preferred Language

It seems to accept in Terminal the following but doesn’t change on relaunch of the App

defaults write au.com.rushsoftware.CrosswordWizard AppleLanguages ‘(“DE”)’

I think it needs to be lowercase fr, de,it,es

The first half? Yes, as shown. Second half is optional, adds localization to the language. Second half is upper cased.

hahaha. Indeed. Sadly my example was taken from Xojo’s docs!

https://documentation.xojo.com/topics/localizing_your_apps/introduction_to_app_localization.html

2 Likes

They need to fix it.

I think I will settle for that and let the system handle the rest. Thanks everyone for the help.

Merry Christmas
Martin

1 Like

In the “beginning” (i.e. from 10.0 to around 10.9), you could also change the language using the Finder’s get info window. Then, as you said, the function disappeared from the UI and is now back.

You should keep spaces instead of replacing them with %20 (Terminal doesn’t use encode-URL strings). Surround the app name with quotes.

The System Settings way does the same but is permanent. Why do you persevere in trying the Terminal way?

1 Like