Serial Port not getting echo

I have a project that sends commands to a robot. I have used Xojo for years and it has always worked.
I just downloaded 2019 R3 and updated it on my Mac.
I got it working just fine.
I then moved it over to my windows machine and it is not working!
To communicate with the robot, I send out a couple of bytes to initiate it. The last byte is a “05”.
This is echoed back. I read it fine.
I then send out “85”. This is echoed back by the robot. I receive it on mac but not on the windows 10 machine. It used to work with the older Xojo.
I have tried putting in delays with app.sleapcurrentthread, xmitwait, SerialPoll, etc.
The only thing that I have been able to get to work is to send the “85” a second time!
I am still using the older Serial as I could not for the life of me get the new SerialConnection to work.

Any ideas why I can’t read this byte?

After I double up this “85” byte all future commands all seem to get echoed back properly!
So I guess I can live with it, I just don’t understand why it is happening.

Start from the beginning…

Is this a desktop or console application you are testing it with?
How are you reading the data? Show us some code, as it may have encoding issues or something else (that may happen to work on macos).

Are you doing the Serial in a thread? Why not just Async ?