Self Assigned IP address

All of a sudden my ethernet connection reports as “Self assigned IP Address” in SysPref (OSX 10.11.5) and won’t connect to the Internet.
This is with a modem to a router to my Lan.
If I disconnect the computer from the router and go directly to the modem it works
I tried another router (older model, no wifi just ethernet), same issue
I replaced the cables… same issue
I recycled, reset both modem and router in every combination I could think of… same issue
I read 100’s of internet topics… same issue
reset DHCP in SysPref, renewed lease, etc. etc… same issue

As of right now I have run out of ideas.
Attempts to communicate with router mfg is a joke. They have no email support… TechSupport via onlyine chat is arrogant, doesn’t speak English, and any other support is $30 (50% the cost of a new device).

So what I am doing as a band-aid… and not sure yet if my TV and DVR internet connections can work this way yet… But I have INTERNET SHARING turned on in my iMac, and IT is working like a wireless router for now.

Just to be clear, you pulled the power on the modem for a few seconds, right?

numerous times, on the router, on the modem, rebooted the computer, reset the router firmware, reset the DHCP server

What ip does your computer have now, private or global?

not sure I understand the question…

When connected via the router (when it worked), the computer(s) on the Lan each had a “private” IP (192.168.2.xxx) and the modem had (I guess it was Public) IP address of 174.66.xxx.xxx

Now the one computer is connected directly to the modem … so it has the 174.66.xxx.xxx IP address

The one other thing I notice (and I don’t know if it matters)

With the ROUTER working… the Subnet was 255.255.255.0
with a direct connection… it is 255.255.252.0

Also just noticed, now that my iMac is playing role of a wireless router … SysPref shows the WIFI now has “self assigned IP”, but that is probably correct, due to the fact the iMac Wifi is sending the “ethernet” connection to the rest of my lan

That’s exactly what I wanted to know.

With the router connected, do your other devices work? In other words, is the problem isolated to your Mac or system-wide?

The router does not talk to the modem…
If I plug it all together as it should be… I can log into the ROUTER from any device and see the routers control panel (192.168.2.xxx)
but the Router says there is no modem attached (and yes I have changed that cable too :slight_smile: )

Before the problem appeared, had you changed cables? It’s not usual today, but some routers require a cross-over cable instead of a straight cable. Your Mac won’t care which type you use.

And just to ask the obvious question, are you sure you plugged the modem into the router’s WAN (or Internet) port?

No changes were made to either hardware or software prior to the problem manifesting itself.
I woke up yesterday morning, and it did not work :frowning:

And :slight_smile: yes, its plugged into the correct port…

[INTERNET]<---yes--->[modem]<---no---> [router]<---yes--->[computer]
[INTERNET]<---yes--->[modem]<---yes--->[computer]

Have you tried reflashing the router back to factory detaults (not just a software reset, but a reflash) ?

And how is that supposed to work?
doubt that would solve anything, as TWO routers (from different mfg) are showing the same issue

It can be the modem. Especialy if your ISP changed your external address overnight. The router was the only live, connected device. Somehow, it is lost on the new config.

You pulled the cable on the modem according to your earlier response. Mine has a battery backup, so pulling the cable does not work. I have to use the reset button. IIf your’s has a similar feature, perhaps the reset button on the modem wil fix the problem.

So… disconnect the router from the modem, reset the modem. Once completely cycled (mine takes a while) then reconnect the router.

Louis… been there done that :slight_smile:
Modem has no battery backup… it has been cycled down and up multiple times, and reset remotely by my ISP twice since this began.

[quote=275626:@Dave S]And how is that supposed to work?
doubt that would solve anything, as TWO routers (from different mfg) are showing the same issue[/quote]

Missed that bit sorry, don’t really know why you went on to contact router tech support then.

Have you recently added a new piece of hardware/software to your network?

You might have two dhcp servers running on your network. One on the router and another somewhere else which is where your machine is getting its IP from.

You might also have an IP conflict with the router where two devices are on its IP.

The new hardware could have been in the last few weeks, DHCP allocated IPs have a timeout, when that timeout happens, the machine will look for an IP again, if the DHCP server isnt there, or there is a problem it will fail then which could be a long time after the change.

Have you tried allocating a fixed IP to the mac while connected to the router (eg. 192.168.0.2.200, something no used) to see if the router is actually passing traffic, or is there a DHCP problem.

Julian… I think I know what you mean, but I’m no network guy. so I am not sure how to do what you suggest,

All I know is the router itself (both of them) indicate an issue… but its just an “idiot light” so no indication WHAT they think the problem is. The only thing I see on the computer side is the Self Assigned message. And I don’t know enough about network protocols to try and change things without know what/why I am doing so.

Ok, first thing to do is go back to basics.

  1. Connect Internet <> Modem <> Router <> Mac unplug everything else.
  2. You know the IP that the router is on 192.168.2.1 for example, then set your Mac to 192.168.2.2 and try to connect to the router via its web interface (assuming it has one) If you dont, then reset the router using its reset button if it has one then check the manual (or the bottom of the router) to see what its default IP and subnet mask is. Set your Mac’s IP to the next value up (last digit +1) and set the subnet mask the same. Set your gateway on the Mac to the IP of the router.

You should have internet access now via the router->modem->internet. Post back either way if you do or dont and we can go on to check your dhcp settings.

Ok… it will be a while… my wife has to get her Facebook fix :slight_smile:
I cannot however see a way to set the subnet mask… it seems to set itself

So to be clear.

  • reconnect modem/router/and ONE computer as normal
  • go to SysPref and Select “Network”
  • select “Ethernet”
  • select “Advanced”
  • Change “Configure IPv4” to “Using DHCP with manual address”???
  • enter 192.168.2.2 (as router IS .1)

How to change “gateway”?

It would be “Manual” not “Using DHCP with manual.” But if you are able to connect to the router via your Mac, I don’t think this is going to be it.