SelectColor hangs in Big Sur

I’m getting user reports that the color picker window opens in Big Sur but can’t be dismissed, one has to force-quit my app. This occurs with 2020r1 and 2020r2. I haven’t seen a Feedback case for this…is anyone else seeing it?

I just tried both Color.SelectedFromDialog() and SelectColor() in Big Sur with 2020r2 and I am able to close the selector with its close button.

Thanks for checking. I’ll have to find a Big Sur machine and try myself.

I could recommend to try NSColorPanelMBS class instead in MBS Xojo Plugins.
But that one is asynchronous, so you get an event when a new color is picked.

1 Like

Thank you.

Was coming here to make a post about this. I am also reporting that the color picker hangs in Big Sur. It works, eventually, but is extremely unresponsive and sometimes locks up for a full minute or longer. This happens inside Xojo itself (for example when selecting the color of a control’s text or using the Insert Color contextual menu command in the code editor) as well as in Xojo-built applications.

I’ve lived with it up until now but it is becoming increasingly frustrating, and I want to make sure the Xojo people are aware of it and working on a fix. Unfortunately one of my apps is a color picker and palette designer, so this is a big problem for me.

If I can provide any additional information, please let me know.

Edited to add:

The only Mac I have that is running Big Sur is an M1 MacBook Air, so it is possible that this is an M1 issue and not a Big Sur issue. Can anyone else running Big Sur confirm, and report if they are on an Intel or M1 Mac?

The Color Picker doesn’t always work for me on macBS either (Intel i9).

In my own apps, I use a NSColorWell (via the declares included in my own Ohanaware App Kit). So the only time this is a problem (for me) is in the Xojo IDE.

Recent I’ve started to use the Apple Digital Color Meter to sample pixels for constant colors. Just make sure you set it to “Display in generic color”.

Can anyone tell us if the color picker in the Color Group editor is exhibiting the same hang?

I can test this right now. How do I use the Color Group editor? I’m not familiar with that.

Nevermind, I figured it out. Strangely, the color picker here seems to work just fine. No hanging and seems responsive.

1 Like

In my experience, the Apple Color picker does work in Big Spur, usually, but not quite always. For some reason there is no OK or cancel button though, so you have to close it with there red dot. No idea why, but it feels inconsistent with what to expect. Big Spur to the left older MacOS to the right.

RIght, so we made the color picker asynchronous for the Color Group editor because the modal picker just didn’t work there. I’m guessing that 11.2 broke something there.

Please make sure that info gets into the bug report.

Is there a Feedback number for this?

I guess you need to create one.

Don’t be snide. I will if no one else has already.

Not being “snide”, as you searched and didn’t find one, just create one.

Of course I will. But since I, personally, can’t reproduce this I have no example to upload, just a secondhand report from a user. I’ve filed upwards of 100 feedbacks, and in my experience reports like this quickly lead to “closed, can’t reproduce”. Since 4 months after my first post others now report they see it, too, it would have preferred to add my comments to amplify a feedback with an example.

Reading above, it was recognized as a problem needing a report, add a link to this conversation too for a future reminder and more context.

And specially don’t forget to cite that part that was specifically requested:

This has been a constant issue for me since 11.0. It’s never worked right on Big Sur. And it happens every time. Whenever I have to use the color picker I have anywhere from 30-90 seconds of lag and it’s very hard to pick the color I want. When I have to change several colors it’s a nightmare.

I’ll file a feedback.


I can confirm that. Got the same problem with Big Sur on M1.