Saving External Build Script

With 2014 release 2, I have been having trouble saving an external build script. I click the … box and open the script file which puts the name of the script file into the File text box. Then I save the project. When I next return to look at the external build script the File text box is empty. I think I can get it to stick if I quit Xojo immediately after saving and then restart. Has anybody else seen this?

Are you by chance saving the external build script to a different drive/volume than where your project lives? If so you have discovered feedback://showreport?report_id=33217. It’s been driving me nuts as I have an internal SSD where I store the OS and Apps, and then an Internal HD where I store all my data. I can’t use external scripts because of this bug. This bug existed in prior versions of Xojo, not just r2. I first discovered it in r1, but that was at the exact time that I installed a SSD too, so not sure when it first started.

In the case I am seeing the external script is on the same drive/volume as the Xojo project. The external script is in a different folder than the project file though. And the problem seemed to start when I put it in a different folder from the project. I think I will look at that some more.

I’m having the same problem. The build script simply disappears from the text field when the build button is clicked or I save after I enter it. I’ve done several builds with a script from App Wrapper Mini that worked prior to 2014r2 but now results in unsigned packages.

I’m seeing this also - drove me nuts this after trying to figure this out!

I’ve run across this problem again in 2015r4 with a build script created by App Wrapper 3. The IDE won’t save it and it disappears as soon as build runs, creating an unsigned app. I have no idea how to resolve this problem.

A reproducible bug report would be a start since the one jeremy mentioned is marked as fixed & verified as fixed

I find it works best if you select something within the project (not the build options) and insert an external script. Save the project, then move it into the correct location.

Xojo does not like when you run it first, then insert an external HD where resides the project you want to run.

When this happens, I quit Xojo and re run it.

FWIW

That worked. Importing a new external script into the project solved the problem as opposed to trying to change the file for a previously imported external script.