Saved webapps only accessible from localhost in macos catalina

To reproduce:
I create new web app, I do not save it, I just run it, either on port 80 or 8080.
A dialog asks “Do you want the application ‘test.debug’ to accept incoming connections?”, I click allow and now i can access the app from any device in my network.

Next, i save the app and I run it again, and now there is no dialog to allow incoming connections, the app just runs, but i can no longer access it from any devices in my network, only from the browser in the same machine.

This issue is preventing me from accessing any of my saved apps on Mac.
I do not have this problem in Windows.

Any pointers on what i need to do?

Try starting it with the command line option:


Thanks for the prompt reply.
I tried “–NetworkInterfaceIndex=0”, which runs only as sudo, but i got same results.
I also tried running the saved executable as sudo, and it worked, it allowed access from the network, without prompting. But it only worked once, any subsequent attempts failed to allow network access.

I will try a few things and report back here later. I want to make sure i’m not missing something obvious first.

What port are you trying to use that you needed sudo?

Thanks @Greg_O_Lone for reaching out.
I found a solution to my problem.
As i suspected, it was something i was missing.
I have always used my Documents folder for all my development folders including Xojo, GitHub, Xcode, and others.
It seems the latest updates to Catalina may have tightened things a little, because i can only access my debug-run apps locally when running them from somewhere inside my Documents folder.
I tested moving my Xojo test app to my home folder and run it from there, and now it works as before and i have access from the network.
I tested making my test app’s folder public inside my Documents folder but it didn’t work.
So, I created a Developer folder in my home folder and i am moving all my development there.
Now when i run a debug or a built app, from somewhere inside my Developer folder in my home folder, i get the macos prompt to allow incoming network connections.
So far all works well.
Does anyone know of a reason i should not do it this way?

80 and 8080