Running web server app on Ubuntu getting errors.

Trying to get my web service to run on Ubuntu and getting errors…
Making sure I have all the right packages installed:

According to the instructions:

sudo apt-get install ia32-libs
sudo apt-get install ia32-libs-multiarch

sudo dpkg --add-architecture i386 /// This failed miserably.
sudo apt-get update
sudo apt-get install ia32-libs-multiarch

Ok… did all this…

brianobrien@opstools:~/Builds - V5.xojo_binary_project/Linux/test$ ./test
Runtime Error
Please report what caused this error along with the information below.
RuntimeCore/ICUStable.cpp: 70
Failure Condition: sLibraryPtr
Could not load ICU library
Aborted (core dumped)

brianobrien@opstools:~/Builds - V5.xojo_binary_project/Linux/test$ ldd test =>  (0xf7781000) => /lib/i386-linux-gnu/ (0xf7769000) => /lib/i386-linux-gnu/ (0xf774e000) => /lib/i386-linux-gnu/ (0xf75a4000)
	/lib/ (0xf7782000)

ohhh dear…

Well, like the error says it “could not load ICU library”. Trying one of the commands to install ICU ought to help:

sudo apt-get install libicu52:i386 sudo apt-get install libicu52

I ran both those command, rebooted and tried again…

Exact same error messages…

I so sad… such a sad sad panda.

buntu@opstools:/home/brianobrien/Builds - V5.xojo_binary_project/Linux/test$ sudo dpkg --add-architecture i386
dpkg: error: unknown option --add-architecture

Type dpkg --help for help about installing and deinstalling packages [*];
Use `dselect' or `aptitude' for user-friendly package management;
Type dpkg -Dhelp for a list of dpkg debug flag values;
Type dpkg --force-help for a list of forcing options;
Type dpkg-deb --help for help about manipulating *.deb files;

Options marked [*] produce a lot of output - pipe it through `less' or `more' !

I wonder if this is because I haven’t installed Xojo on the linux machine and am cross compiling…

Xojo does not need to be installed. In fact if you cannot get libicu installed Xojo will likely not run at all.

Both of these command succeeded.

sudo apt-get install libicu52:i386 sudo apt-get install libicu52

Would you assume that that libicu isn’t installed?

Made a new VM Using 32 bit Ubuntu… It just worked. No problems no additions.