Running on Centos Vps

Hi ,
Just starting out with web edition, testing for the past week and going nowhere faster.

Just using the examples, as is no alterations. As a standalone all I get is segmentation fault every time.
As cgi "unable to launch application MyApplication on port 7567, this with auto ports and selecting a port, no difference.

Running on VPS running Apache with Centos 6 x86 64. unmananaged so I can alter what ever.

Read everything I could find here and google, install 32 bit libs, open firewall, check permissions.

Now I am totally clueless as where to go next, hence the plea for some assistance please.

First of all, with a CGI app, you don’t need to open the firewall port. The port # is used for communication between the CGI file and the application itself.

Things to check:

  1. Make sure you compiled for Linux. Many beginners forget, compile for OS X and because the files look identical they don’t notice it.

  2. Make sure you are uploading the “Libs” directory. There are a bunch of plugins in that folder that are needed for the application to run properly.

  3. Try launching the app from the command line. More helpful information may be displayed there.

  4. Make sure the .cgi, executable and the Libs folder (and contents) are all set to be executable. The config file should be RW. It’s likely that the app is being run under the account that runs apache (unless you’ve set the SUID bit)

when uploading, make sure you do it in Binary mode, not ASCII mode. ASCII mode will destroy the apps.

Hi,

I have ensured that it is built for Linux , I delete the build folder after each different attempt between standalone and cgi.
Every thing is uploaded using filezilla, tried with auto transfer, binary and ascii, permissions are set 0755 on all dirs and files.

From the command line I get : status 200 OK Content-type text/plain unable to launch application MyApplication on port 48882

I have tried consistently using the information in the docs and on the forum to resolve this.

What about the segmentation fault ? accessing memory ?

Have you checked SELinux? On a CentOS box it is responsible for 90% of all strange behavior.

Hi Yes, having read another post. it shows as disabled.

My config file is set to 644 not 755 (just checking since you said all your files were set to 755). Is the file in the CGI-Bin folder (Not sure if that’s an issue) ? I know it’s frustrating there’s no rule book that fits every server. Hope you get this solved.

Hi,
I have tested it seperately with every combination of permissions and I can tell you for sure the config file at 755 is not an issue.
I use a cgi-bin but is not necessary as I have addHandler for using a cgi script from any directory.

Anyway, Thankyou all for your input. I finally have seen my little example app running…Whoopeee

The problem was permissions on the actual application.cgi file. I use FileZilla for ftp and even though I was setting the required permissions using the ftp program, I then checked the permissions in the filemanager on the server and found that they were not set to executable. Once corrected off we went… of now to actually experiment with this web software and try to produce an app.

Thank You.