Running a project from Project (text) format

Ok, another embarrassing question from a relatively new Xojo developer. I’m experimenting with both SVN and Git for version control, so started saving my project in text format (Xojo Project Format) instead of binary to test version control out. After doing this for a couple days, I noticed that if I save a perfectly fine binary project in text format and then run that project by double-clicking on the text format project file, it seems to run fine unless I run a method that loads a WebDialog while in a WebContainer. In such a case that WebDialog is shoved towards the right lower corner and it loses its surrounding larger rectangle. However, if I run the same project by double-clicking on its binary project file, this problem isn’t present.

Oh my. If you can reliably create this issue in a new project, create a bug report and attach the projects.

I can:

  1. Open the binary file with Xojo and make sure the problem is not present. It’s not.
  2. Save as text (Xojo Project).
  3. Open the project text file with Xojo and make sure the problem IS present. It is.
  4. Before closing the project that was open from text, save it as binary.
  5. Now run the NEW binary file with Xojo. Now that problem is there.

So the Save As Xojo Project corrupts something. I thought perhaps I wasn’t supposed to run it from text when I saw this, and thought others here would tell me that.

Doesn’t do any good to tell us here (other than to inform us about the issue). Submit it to Xojo via the Feedback application. That’s the official way to submit bugs.

Just finished the bug report with a simple file to demonstrate it: #43266

Just as I was getting excited that I could do Version Control with Xojo if I saved projects in text format. Never could do that with Filemaker.

Well, we do all our projects in Text Format. Just haven’t run into this bug (yet).

Web dialogs have all kinds of weird issues. For example, they don’t fire Resized: <>

Just got Feedback response. Supposed to be resolved in future release.

Just downloaded the new release (2016 rel 1). It fixes this bug.