Run Xojo 2017 release 3 in pc on a domain joined pc

Hello everyone,

We are trying to run any project in 64 bits in the 2017 release 3 version on PCs that are joined to an Active Directory domain but when you compile the program hangs completely and you have to start over. Anyone else has happened? If we remove the domain pc it works fine and we don’t have any policy that blocks it.

Thanks for the help

In my experience, being a member of an Active Directory Domain should not be affecting your ability to compile an application. However, I have experienced antivirus software blocking the ability to compile. If you can temporarily disable your antivirus software and then try to compile you may find that to be the solution.

This is not to say that there might be some AD GPO setting that prevents compiling an executable, but it is more likely to be antivirus software assuming compiling an application is suspicious activity.

Talk to your IT dept and see if they restrict apps that spawn other processes. The IDE does a lot of that with compiling and linking.

Thanks Tom, we have tried removing the antivirus and the same thing happens to us and also removing the windows firewall and the result is the same.

Any more ideas?

Try opening a shell and launching the IDE from there. You may get messages there when the IDE is struggling.

Just out of curiosity, what do you have the Optimization Level set to on the Shared Settings panel? If it’s set to anything other than Default, it could just be that it’s taking a long time…

Make sure the user has local administrative rights or logon with a local user account with administrative rights. Check your GPO policies to see if Greg’s suggestion may be the culprit.

Can you run the app in the debugger or does this happen in both the debugger and compiling an executable?

Hello Tom,

The same thing happens to us if we start with a local user but the computer is attached to the domain. If we remove the domain computer, it works.

Hmmmm… You might want to check with your network folks to see if you have some sort of network based endpoint management that stops “suspicious activity”. You probably can get the computer “white listed” to allow you to compile.

There was a problem way back where a folder path that included a folder with a “.” would cause problems. For example, C:\Users\Wayne.AxisDirect\Documents would cause the issue. This folder would be created by the OS when the user has both a local & domain account on the machine.

Hi Wayne,

Our private users can cause problems since they have “.” but I have run the desktop app on a local user (but domain joined machine) and it doesn’t work. From what I understand that is not the problem.

Hello Tom,

From the comms department it tells us that there is no such lock. What I was commenting on is that if the machine is in the domain it does not work, if it is outside the domain it works

David, I’m about out of ideas for you. I run Xojo on a corporate Active Directory Domain and have for many years. I am not aware of any specific Group Policy that would block Xojo from compiling an app, but there may be a combination that might. Without knowing which GP objects are applied and in what order this may be hard to figure out. You can try asking your IT folks to put your PC into a default OU that doesn’t apply the normal GPO policies and if that works you will know that the defined Group Policy is the problem. After that it would be a matter of trial and error to puzzle out which policy being applied breaks Xojo. Your IT may allow an exclusion for this machine for the normal policy if they are like the IT folks I work with.

@David_Pena did you try this?